attachments are inlined and they shouldn't be

VERIFIED DUPLICATE of bug 65794

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 65794
16 years ago
9 years ago

People

(Reporter: Ian Elverson, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Wehn you attach a file to an email generated by the Mozilla mail client, the 
Content-Disposition is set to 'inline'.  It should be set to 'attachment'.  
This can confuse some mail servers and clients.  I have included the header of 
a test message to give you an example...

From: Ian Elverson <elverson@ironsite.com>
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: ian1@ironsite.com
Subject: inline test
Content-Type: multipart/mixed;
 boundary="------------060101070900000608010102"

This is a multi-part message in MIME format.
--------------060101070900000608010102
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

    hi

--------------060101070900000608010102
Content-Type: application/x-msexcel;
 name="ats1.xls"
Content-Transfer-Encoding: base64
Content-Disposition: inline;
 filename="ats1.xls"

This problem is fixed in Netscape 6.x, but it exists in 4.7x, so I would assume 
the Mozilla codebase came from Netscape 4.x.

Updated

16 years ago
QA Contact: gayatri → trix
Duplicate of "Some attachments get Content-Disposition: inline (incorrect)"

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verifying dupe
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.