Default Search Engine configured from a web extension not migrated to 57.0.x

RESOLVED DUPLICATE of bug 1426081

Status

()

defect
RESOLVED DUPLICATE of bug 1426081
2 years ago
2 years ago

People

(Reporter: vivek_subramanian, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.84 Safari/537.36

Steps to reproduce:

1) Install any pre Firefox 57 version

2) Load a extension from "Debug-Addons" UI -> "Load Temproary Add-On" UI and load a (Addon-SDK) legacy extension which adds a Search provider to the list but does not set as default.

For ex:- Assume my Search provider name is "WNZSearch" and domain it configures is WNZSearch.com to the list of search providers by our extension

3) Close and relaunch FF to remove the extension which we loaded, but the Search provider which was added from this extension is not removed and stays. I mean WNZSearch continue's to stay in list of search providers

4) Install Firefox 57 over it

5) Install the new Web Extension which tries to add and configures "WNZSearch"  as the default search engine (This is a new web extension which sets same domain as 
default search engine) - So WNZSearch will be set as default Search engine

6) Click "Yes" from the dialog which asks "WNZSearch would like to change your default search engine from Google to WNZSearch. Is that OK"

7) WNZSearch set as default Search provider

8) Update to FF 57.0.2 OR FF 57.0.1




Actual results:

Google is reset as default search engine after 57.0.2 update


Expected results:

Since I had installed the web extension with FF57 browser on which I clicked "Yes" from "would like to change your default search engine from Google to WNZSearch. Is that OK" dialog, I expect WNZSearch should be retained as default search engine.

I am from Symantec and its affecting lot of our customers
Component: Untriaged → Search
We are also affected by this with our extension (https://addons.mozilla.org/de/firefox/addon/ecosia-the-green-search/).
But it seems our bug report for this issue has been deleted: https://bugzilla.mozilla.org/show_bug.cgi?id=1426081
Hi,

Gentle Reminder - Any updates we can expect from Firefox to resolve this issue ?

We see our customers affected because of this issue.
Duping forward to bug 1426081 as that has a patch already.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426081
You need to log in before you can comment on or make changes to this bug.