If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add "Do Not Edit" warning to prefs.js

VERIFIED DUPLICATE of bug 142590

Status

Core Graveyard
Profile: BackEnd
VERIFIED DUPLICATE of bug 142590
16 years ago
2 years ago

People

(Reporter: Andrew Hagen, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
 

Comment 1

16 years ago
nothing here. Invalid.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

16 years ago
Weird. Must have been truncated or something. Maybe because I had a Javascript
comment in my Bugzilla comment?

Here's the bug description again:

To prevent profile corruption, we need to improve the warning in prefs.js
against editing the file. Currently the warning is (I will omit the Javascript
comment character string):

This is a generated file!

We need to change this to something like (enclosed as a comment):

This is a generated file! Do not edit. To make a manual change to preferences,
create a text file, user.js, and put it in the same directory as prefs.js.
Entries in user.js override entries in prefs.js
Blocks: 123929
Status: RESOLVED → REOPENED
Component: Browser-General → Profile Manager BackEnd
Keywords: mozilla1.0, nsbeta1
Resolution: INVALID → ---
Summary: Add 'do not edit → Add "Do Not Edit" warning to prefs.js

Comment 3

16 years ago
So weird that you duped it two bugs later :-)

*** This bug has been marked as a duplicate of 142590 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Now I think I've figured it out. I hit enter in one of the fields while I was
editing the bug. Then I hit escape. I thought that canceled the bug's creation.
Then, I saw what looked like a half bug, and tried to fill it out. My fault. Sorry.

Comment 5

16 years ago
Invalid bugs shouldn't be resolved as duplicates.
Nor should they be dup'ed when identical bugs are submitted by the same
reporter, for that matter. The last week i've seen bugs nearly hit the mostfreq
list by duplicates submitted by one person alone.
(Reporter)

Updated

16 years ago
No longer blocks: 123929

Comment 6

15 years ago
Verified as a dupe of bug 142590 to close it out. Shouldn't bug 142590 be
resolved as invalid? 
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.