Closed Bug 1425895 Opened 2 years ago Closed 2 years ago

Daily 59.0a1 (2017-12-18) (64-bit) Prints Only a Blank Page (Windows only)

Categories

(MailNews Core :: Printing, defect)

All
Windows
defect
Not set

Tracking

(thunderbird59 affected)

RESOLVED FIXED
Thunderbird 59.0
Tracking Status
thunderbird59 --- affected

People

(Reporter: bugzilla.mozilla.org, Assigned: Paenglab)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171206182557

Steps to reproduce:

I try to print any email message and, each time, only a (one) blank page comes out.  I did try using Safe Mode.  I have also completely deleted and re-installed the Printer.

Daily 59.0a1 (2017-12-18) (64-bit) 

I have TWO printers.  I have tried both of them.  Same result.  One is an Epson Color Inkjet, the other is a Brother B&W Laser.


Actual results:

Only a (one) blank page gets printed.


Expected results:

The email should have been printed.
Confirmed, I also can't print to PDF. Alice could you please find the regression for us.
Status: UNCONFIRMED → NEW
Component: Untriaged → Printing
Ever confirmed: true
Flags: needinfo?(alice0775)
Product: Thunderbird → MailNews Core
(We should switch m-c to chromium to avoid the such regression.)
Thanks Alice!

C.J. and Jonathan: Can you please advise us what we need to do/port/adapt in Thunderbird to get printing going again.

Our print code is here:
https://dxr.mozilla.org/comm-central/source/mailnews/base/src/nsMsgPrintEngine.cpp
and related files: https://dxr.mozilla.org/comm-central/search?q=file%3Amsgprint&redirect=true
Flags: needinfo?(jwatt)
Flags: needinfo?(cku)
on local build,
last good: e38c56824a75
first bad: a3362670656e
Thank you, so that would make https://hg.mozilla.org/mozilla-central/rev/a3362670656e the offender. That appears to be a Windows only patch. Does printing still work in Daily on Mac or Linux?
Flags: needinfo?(richard.marti)
Mac prints correctly to a printer. I tested Linux only to PDF and this worked.
Flags: needinfo?(richard.marti)
Hi Mark/Jorg,
We create PrintTargetEMF only if mPrintViaSkPDF is true[1]. And I do not expect mPrintViaSkPDF being 'true' in m-c. Can you set a breakpoint inside nsDeviceContextSpecWin, and see why we get 'mPrintViaSkPDF == true' in your env?

[1] https://hg.mozilla.org/mozilla-central/file/a3362670656e/widget/windows/nsDeviceContextSpecWin.cpp#l209
Hi C.J., thanks for the comment.

I started looking at the problem and it turns out that with my local debug build of 2017-12-21 I *can* actually print. I tried a few server builds (of 21st and 24th), both opt and debug and they all don't print.

In cases like this, it's most likely a packaging error, so the server builds are missing something that we need to add to our package-manifest.in.

C.J., are there any packages that we need now for printing they might not be included in TB? Bug 1399787 didn't add to the package manifest, but something might already be included in FF that's not in TB. Or there's a mozconfig option missing or wrong.

Richard, you have a local Windows opt build, does that print?
Flags: needinfo?(richard.marti)
OS: Unspecified → Windows
Hardware: Unspecified → All
Summary: Daily 59.0a1 (2017-12-18) (64-bit) Prints Only a Blank Page → Daily 59.0a1 (2017-12-18) (64-bit) Prints Only a Blank Page (Windows only)
Yes, the local build prints.
Flags: needinfo?(richard.marti)
Bug 1399787 used a dll which was added into package manifest month ago in
https://hg.mozilla.org/mozilla-central/rev/68db42ac8c23
Attached patch pdfium.dll.patchSplinter Review
Thank you C.J. This fixes the printing issue.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(jwatt)
Flags: needinfo?(cku)
Attachment #8938854 - Flags: review?(jorgk)
Comment on attachment 8938854 [details] [diff] [review]
pdfium.dll.patch

Nice. Thanks, landing now.
Attachment #8938854 - Flags: review?(jorgk) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9edc25fc05b9
Add pdfium.dll to package manifests to make printing work again under Windows. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 59.0
Depends on: 1427109
You need to log in before you can comment on or make changes to this bug.