Catch Java plugin crashes and handle them properly

RESOLVED DUPLICATE of bug 62460

Status

RESOLVED DUPLICATE of bug 62460
17 years ago
6 years ago

People

(Reporter: stan, Assigned: blackconnect)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When the java plugin or VM from Sun crash or any plugin crashes I think, Mozilla
gets taken down too.  This is not a reasonable behaviour.

Right Now = Java VM/Plugin Crash -> Mozilla Crashes -> exits
Future? = Java VM/Plugin(Any) Crash -> Interally Handle this -> Output page
explaining error to user like "Plugin %s crashed, page cannot be displayed
normally" and do NOT force the browser to exit with an INTERNAL ERROR.

This is especially annoying on Linux (Plugins tend to crash more on Linux/Unix,
especially Java) and in Mail and News on either platform when Java causes
Mozilla to crash.  A crash handler that allows operation to continue despite a
backend crash would be a major improvement.

Best Regards,

Stan

Comment 1

17 years ago
Resolving as dup of bug 62460, since Linux is mentioned in particular.

The java plugin is special in that it usually provides it's own crash reports
(written to file). And many of the crashes Linux users see in Mozilla with the
Java plugin are due to wrongful installation. (Forgetting to symlink it, and
using a copy instead)

Related: bug 36272, bug 59653

*** This bug has been marked as a duplicate of 62460 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Component: Java-Implemented Plugins → Java-Implemented Plugins
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.