Closed Bug 142596 Opened 18 years ago Closed 18 years ago

Links opened in new window should inherit "back" history

Categories

(SeaMonkey :: UI Design, enhancement)

x86
Windows 2000
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 18808

People

(Reporter: sockbot, Assigned: samir_bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020506
BuildID:    2002050604

When opening a link into a new tab or window, the back button history should be
inherited.

Reproducible: Always
Steps to Reproduce:
1. Open a link in new window/tab
2. Go to newly opened window/tab
3. Back button is greyed out (no history)

Actual Results:  The new page opened is started as a new root to the history-line.

Expected Results:  The new page opened should be treated as a fork from the
history-line.

I think this should be expected behaviour because it makes sense to me
conceptually. Sometimes I open a bunch of links to new windows from a site, and
then on the final "link of interest" open it in the original window. Since only
one window has the complete "back history" I have to carefully monitor which one
it is to avoid closing it by accident.

*** This bug has been marked as a duplicate of 18808 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.