Provide a CLI for generating summary metrics for shield pref-flipping experiments

RESOLVED DUPLICATE of bug 1485804

Status

P3
normal
RESOLVED DUPLICATE of bug 1485804
a year ago
3 months ago

People

(Reporter: harter, Assigned: harter)

Tracking

Details

(Assignee)

Description

a year ago
I want to be able to easily generate summary metrics for a shield pref-flipping experiment.  I'd like the metrics to be output in a textual format so they can be included in a report and annotated.

I'd like the initial set of metrics to be percentage changes between experiment and base for 4-5 metrics with an included confidence interval.  The confidence interval would ideally not rely on a normal hypothesis.

An initial set of metrics could include:

* Session Length
* URI Counts
* Total Searches
* Crashes

Eventually, I'd like there to be similar functionality for all experiment results used to make a decision.  I.e. I'd like all experiment summary tools to have textual export functions.
(Assignee)

Updated

a year ago
See Also: → bug 1397298
(Assignee)

Updated

a year ago
Duplicate of this bug: 1394612
(Assignee)

Comment 2

11 months ago
Unlikely I'll make progress in Q1. Hoping to tackle this in Q2
Priority: P1 → P3
(Assignee)

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1485804
You need to log in before you can comment on or make changes to this bug.