Closed Bug 1426527 Opened 2 years ago Closed 2 years ago

test_getCoalescedEvents.html and test_remove_frame_when_got_pointer_capture.html are going to permafail when Gecko 59 merges to Beta on 2018-01-11

Categories

(Core :: DOM: Events, defect, P1, critical)

defect

Tracking

()

VERIFIED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 + verified

People

(Reporter: RyanVM, Assigned: stone)

References

Details

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]: Permafailing tests on the next merge day.

https://treeherder.mozilla.org/logviewer.html#?job_id=152720168&repo=try

I'm assuming that's a feature not meant to be riding the trains yet.
Flags: needinfo?(sshih)
Summary: test_getCoalescedEvents.html is going to permafail when Gecko 59 merges to Beta on 2018-01-11 → test_getCoalescedEvents.html and test_remove_frame_when_got_pointer_capture.html are going to permafail when Gecko 59 merges to Beta on 2018-01-11
Blocks: 1420589
Assignee: nobody → sshih
Flags: needinfo?(sshih)
Checked the failed test cases and they pushed required preferences before starting. Still trying to figure out the cause. Wondering how to set up the environment to reproduce the failures in local?
Flags: needinfo?(ryanvm)
(In reply to Ming-Chou Shih [:stone] from comment #1)
> Checked the failed test cases and they pushed required preferences before
> starting. Still trying to figure out the cause. Wondering how to set up the
> environment to reproduce the failures in local?

I guess it can be reproduced by changing EARLY_BETA_OR_EARLIER from 1 to null, right?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #0)
> [Tracking Requested - why for this release]: Permafailing tests on the next
> merge day.
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=152720168&repo=try
> 
> I'm assuming that's a feature not meant to be riding the trains yet.
I plan to enable pointer event in the release build and ride the train of FF59. But this should be fixed first, right?
(In reply to Ming-Chou Shih [:stone] from comment #1)
> Checked the failed test cases and they pushed required preferences before
> starting. Still trying to figure out the cause. Wondering how to set up the
> environment to reproduce the failures in local?

NIGHTLY_BUILD/RELEASE_OR_BETA are usually the ifdefs that matter here, and they're set by configure based on the version number. The patch below should suffice for reproducing.
https://hg.mozilla.org/try/rev/d69a5517d881095f95b5599cc40342d57be49792

(In reply to Ming-Chou Shih [:stone] from comment #3)
> I plan to enable pointer event in the release build and ride the train of
> FF59. But this should be fixed first, right?

Depends on your timeframe, but if that's the case, I can just work around the failures by skipping the tests in my Try runs for now. Please make this bug block whatever bug is blocking that enabling, though.
Flags: needinfo?(ryanvm)
Tracking for 59, so that we'll remember to follow up in January before the merge.
Regarding the failure of test_remove_frame_when_got_pointer_capture.html, the symbols setPointerCapture is not dynamically added when pushing the preference of pointer event. It works when creating a new window/document. Revise the test case by creating an iframe for testing after pushing the preference.
Regarding the failure of test_getCoalescedEvents.html, it's because the current implementation doesn't support dynamically change the preference of mouse move coalescing. But I think it's time to let it ride the train of FF59 since it's already enabled in nightly builds for a while.
Depends on: 1403743
Priority: -- → P1
Attachment #8938698 - Flags: review?(bugs)
Comment on attachment 8938698 [details] [diff] [review]
Revise test_remove_frame_when_got_pointer_capture.html to correctly run the test in release build

This patch is marked obsolete. I assume I'm not supposed to review this.
Attachment #8938698 - Flags: review?(bugs)
(In reply to Olli Pettay [:smaug] from comment #9)
> Comment on attachment 8938698 [details] [diff] [review]
> Revise test_remove_frame_when_got_pointer_capture.html to correctly run the
> test in release build
> 
> This patch is marked obsolete. I assume I'm not supposed to review this.

oops, wrong attachment.
Attachment #8939444 - Flags: review?(bugs)
Attachment #8939444 - Flags: review?(bugs) → review+
Comment on attachment 8939444 [details] [diff] [review]
Revise test_remove_frame_when_got_pointer_capture.html to correctly run the test in release build

Confirmed that this patch plus the one in bug 1403743 makes everything green :)
Attachment #8939444 - Flags: feedback+
(In reply to Ryan VanderMeulen [:RyanVM] from comment #11)
> Comment on attachment 8939444 [details] [diff] [review]
> Revise test_remove_frame_when_got_pointer_capture.html to correctly run the
> test in release build
> 
> Confirmed that this patch plus the one in bug 1403743 makes everything green
> :)

Thanks!
Pushed by sshih@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/44f6455da33e
Revise test_remove_frame_when_got_pointer_capture.html to correctly run the test in release build. f=RyanVM. r=smaug.
https://hg.mozilla.org/mozilla-central/rev/44f6455da33e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.