Closed Bug 1426675 Opened 2 years ago Closed 2 years ago

JS module test instantiation-error-3.html fails

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(1 file)

The following web platform test is currently expected to fail:

html/semantics/scripting-1/the-script-element/module/instantiation-error-3.html
This is problem with the test.  The third module script is marked 'async' which means it can run at any time, but the test assumes a specific order.

The fix is to remove the 'async' attribute.  Note that the purpose of the test is not related to script ordering.
Attachment #8938364 - Flags: review?(james)
Attachment #8938364 - Flags: review?(james) → review+
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/afef4f6c9875
Fix test code that makes incorrect assumptions about when scripts are run r=jgraham
Duplicate of this bug: 1426195
https://hg.mozilla.org/mozilla-central/rev/afef4f6c9875
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.