remove tcanvasmark from talos

RESOLVED FIXED in Firefox 59

Status

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jmaher, Assigned: rwood)

Tracking

unspecified
mozilla59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [PI:January])

Attachments

(1 attachment)

many years ago, :snorp had requested that we run tcanvasmark on talos.  This has been running for years, and catching a regression here and there.  In chatting with snorp last week it seemed clear that there is little real value we get from tcanvasmark today.  :snorp did suggest that we might want to replace it with something, although there was nothing he could recommend in the brief conversation we had.

I vote for disabling the test and when we have a replacement we add it when ready.
:snorp, can you give the OK to disable this test, and/or offer guidance on what you think would be any next steps?
Flags: needinfo?(snorp)
I think it's fine to disable -- we no longer really care about canvas 2d performance, AFAIK. Maybe it would be good to get signoff from Milan too?
Flags: needinfo?(snorp) → needinfo?(milan)
I wouldn't say we don't care about canvas 2d performance, but it sounds like this isn't really useful at this point, so I'm happy to turn it off.
Flags: needinfo?(milan)
Assignee: nobody → rwood
Whiteboard: [PI:January]
I also removed it from: https://wiki.mozilla.org/Buildbot/Talos/Tests
Comment on attachment 8943744 [details]
Bug 1426682 - Remove tcanvasmark from talos;

https://reviewboard.mozilla.org/r/214136/#review219848

looks like you found all the places!
Attachment #8943744 - Flags: review?(jmaher) → review+
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ff0fdb03af33
Remove tcanvasmark from talos; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/ff0fdb03af33
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.