[PP] Crash when attempting to read newsgroups

VERIFIED FIXED in M11

Status

defect
P3
critical
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: sford4, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

seth i am on Mandrake 6, i pulled today around 6pm
news://news.mozilla.org/netscape.public.mozilla.builds
Assertion: "nsMsgDBEnumerator broken" (NS_SUCCEEDED(rv)) at file
nsNewsDatabase.cpp, line 296
Break: at file nsNewsDatabase.cpp, line 296
Assertion: "CreateNewHdr didn't fail, but it returned a null newMsgHdr"
(newMsgHdr) at file nsNNTPNewsgroupList.cp
p, line 590
Break: at file nsNNTPNewsgroupList.cpp, line 590
Assertion failure: NS_SUCCEEDED(rv), at nsNNTPProtocol.cpp:3138

Program received signal SIGABRT, Aborted.
0x402acee1 in __kill () from /lib/libc.so.6
(gdb) where
rror.mozilla.org/webtools/tinderbox/SeaMonkey/panel.html
á5panel_content=chrome://bookmarks/content/bm-panel.xulà¡
#2  0x401afe8b in PR_Assert (s=0x4155130d "NS_SUCCEEDED(rv)", file=0x41550825
"nsNNTPProtocol.cpp", ln=3138)
    at prlog.c:480
#3  0x41531950 in nsNNTPProtocol::ReadXover (this=0x8c70b50,
inputStream=0x8e05930, length=1920)
    at nsNNTPProtocol.cpp:3138
#4  0x41535607 in nsNNTPProtocol::ProcessProtocolState (this=0x8c70b50,
url=0x8e0cfcc, inputStream=0x8e05930,
    sourceOffset=128, length=1920) at nsNNTPProtocol.cpp:4701
#5  0x41147e84 in nsMsgProtocol::OnDataAvailable (this=0x8c70b50,
ctxt=0x8e0cfcc, inStr=0x8e05930,
    sourceOffset=128, count=1920) at nsMsgProtocol.cpp:161
#6  0x409b0cc6 in nsOnDataAvailableEvent::HandleEvent (this=0x41405e38) at
nsAsyncStreamListener.cpp:344
#7  0x409b045e in nsStreamListenerEvent::HandlePLEvent (aEvent=0x41405e38) at
nsAsyncStreamListener.cpp:144
#8  0x401993ab in PL_HandleEvent (self=0x41405e38) at plevent.c:509
#9  0x4019929c in PL_ProcessPendingEvents (self=0x808e520) at plevent.c:470
#10 0x4015a080 in nsEventQueueImpl::ProcessPendingEvents (this=0x8072090) at
nsEventQueue.cpp:118
#11 0x4057b6bd in event_processor_callback (data=0x8072090, source=7,
condition=GDK_INPUT_READ)
    at nsAppShell.cpp:153
#12 0x40770981 in gdk_get_show_events () from /usr/lib/libgdk-1.2.so.0
#13 0xc24748b in ?? ()
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed.  this will no longer call PR_ASSERT().

PR_ASSERT() is evil, as it calls abort().

I did a scan through mozilla/mailnews/news and replace all PR_ASSERT() with
NS_ASSERTION() which are better because:

they only do a printf, or on windows, launch you into the debugger and they only
do that on release builds.

sford:  if you have cycles, can you do a search (with lxr) for all places in the
code that calls PR_ASSERT() and log bugs against the author, explaining how on
UNIX this will call abort() which is never good.

Now, about the assertion.

can you try a later build and see if you get the same assertion.  if yes, reopen
this bug, and change the summary to "assertion when attempting to read
newsgroups"
Target Milestone: M11
Status: RESOLVED → REOPENED
Win_nt 4.0 (1999-09-27-09 M11)
Linux (1999-09-27-08 M11)
Reading newsgroup on Win_nt works fine. But not on Linux.
Steps:
1. Select news.mozilla.org news server from Messenger
2. Select netscape.test.
3. Read any news posting.  It displays.
4. Select another one. It gets hung up. Consistently reproducible twice. It gets
hung up in the second one. Unable to get stack trace because when I did a
./mozilla-apprunner -g   and
r -mail
It GDB terminates abnormally, segmentation fault. Re-open this bug.
Resolution: FIXED → ---
Severity: normal → critical
QA Contact: lchiang → huang
Summary: Crash when attempting to read newsgroups → [PP] Crash when attempting to read newsgroups
Fenella - can you read another newsgroup besides netscape.test?
I had problem for migration on Linux yesterday.
But I will try that later today!
Hey, I tried to create new account from 5.0 (9/27 build) for the news server.
I didn't crash at this time. The window hung. I won't surprise that
since there was a blocker bug#14773 which I already opened on 9/23.
The bug is contents are: "Not able to select server/folders' name from the new
folder/subscribe dialog". So if this bug cannot fix, we cannot subscribe another
newsgroup for further testing.
Same build as the original report. I try to read another newsgroup,
netscape.public.mozilla.mail-news, the result is the same. It gets hung up when
I read the second news message. When I read the postings in
netscape.public.test, it gets hung up in the third message.
Passed by retest on the 10-01-09-M11 build / Linux platform:
I can read msgs from newsgroup, and I can subscribe another new newsgroup, too.

(Actually, this bug was duplicate of bug#14266, I just subscribed another
new newsgroup to verify that this bug passed,too)

I still leave this reopened since it not marked Resolved Fixed yet, but just let
you that it's working fine now.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
marking fixed.
Status: RESOLVED → VERIFIED
Passed by retest on 10-08-12-M11 commercial build for all the Win98, WinNT, mac
& Linux platfoems:

No Crash anymore for reading messages for the newsgroup.
OS: Linux → All
Changed platforms to all since I verified on all the platforms
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.