Closed Bug 1427378 Opened 3 years ago Closed 1 year ago

[PDFium] Print preview on RTL document is shifted to the left

Categories

(Core :: Printing: Output, defect, P3)

x86
Windows 10
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox59 --- affected

People

(Reporter: StefanG_QA, Unassigned)

References

Details

Mozilla/5.0 (Windows NT 10.0; rv:59.0) Gecko/20100101 Firefox/59.0 (20171229100308)

Make sure to add the following pref: print.print_via_pdf_encoder : skia-pdf

1. Launch Firefox
2. Open this *.pdf RTL sample file (https://drive.google.com/file/d/1jLdoZNfHvTqhT_uJocjQ85xCdYLZrgJP/view?usp=sharing)
3. Print Preview the page
4. Set scale to 100% 
5. Print the test document
6. Compare the page with the actual document
7. Print Preview the page
8. Set scale to Shrink to Fit
9. Compare the page with the actual document

AR: If the scale is set to 100% the whole text is shifted to the left on the Print Preview. The page is printed correctly
However if the scale is set to "Shrink to Fit" the page is shown/printed correctly.

ER: Print preview and actual print should be identical 

Scale 100%:  https://St3fQA.tinytake.com/sf/MjE5NzMzN182ODE3NDY4
Scale Shrink to Fit:  https://St3fQA.tinytake.com/sf/MjE5NzMzOF82ODE3NDY5
OS: Windows → Windows 10
Blocks: 1399787
Assignee: nobody → cku
Assignee: cku → nobody
Hi Stefan,

I looked into this bug a little bit.
But I couldn't reproduce this phenomenon on PDFium environment, and I want to hear the reproducing step.

Before that, Can you reproduce this bug for now?
Current print preview with 100% scale seems to me that works well. (i.e. all text is not shifted)
Flags: needinfo?(stefan.georgiev)
Mozilla/5.0 (Windows NT 10.0; rv:60.0) Gecko/20100101 Firefox/60.0 (20180131100706)

I`m still able to reproduce the issue on Windows 10 x86 using latest (32-bit) Nightly build following the below steps: 

1. Launch latest Nightly build
2. Open this *.pdf RTL sample file (https://drive.google.com/file/d/1jLdoZNfHvTqhT_uJocjQ85xCdYLZrgJP/view?usp=sharing)
3. Use printing shortcut "Ctrl + P"
4. Navigate to the hamburger menu and choose the "Print" option
5. Set scale to 100% and orientation to "Portrait"
6. Print the test document
7. Compare the page with the actual document


AR: If the scale is set to 100% the whole text is shifted to the left on the Print Preview. The page is printed correctly
ER: Print preview and actual print should be identical 

NOTE: The issue is not reproducible on Windows 10 x64 using latest Nightly build (64-bit)
Flags: needinfo?(stefan.georgiev)
Thanks, Stefan.

(In reply to Stefan [:StefanG_QA] from comment #2)
> Mozilla/5.0 (Windows NT 10.0; rv:60.0) Gecko/20100101 Firefox/60.0
> (20180131100706)
> 
> I`m still able to reproduce the issue on Windows 10 x86 using latest
> (32-bit) Nightly build following the below steps: 
> 
> 1. Launch latest Nightly build
> 2. Open this *.pdf RTL sample file
> (https://drive.google.com/file/d/1jLdoZNfHvTqhT_uJocjQ85xCdYLZrgJP/
> view?usp=sharing)
> 3. Use printing shortcut "Ctrl + P"
> 4. Navigate to the hamburger menu and choose the "Print" option
> 5. Set scale to 100% and orientation to "Portrait"
> 6. Print the test document
> 7. Compare the page with the actual document
> 
> 
> AR: If the scale is set to 100% the whole text is shifted to the left on the
> Print Preview. The page is printed correctly
> ER: Print preview and actual print should be identical 
> 
> NOTE: The issue is not reproducible on Windows 10 x64 using latest Nightly
> build (64-bit)

Umm, I guess I can reproduce this phenomenon, but I'm not sure my environment is same to Stefan's environment.

Stefan,
I would be wonderful if you can confirm the following thing:
 * What is the paper size which is using for?
   (You can see paper size in your printer driver settings)
Flags: needinfo?(stefan.georgiev)
The printer (HP LaserJet Pro MFP M225dw) that we used for testing is using the default settings.

Paper sizes: A4 210 x 297 mm / 8.27 x 11.69 inches
Flags: needinfo?(stefan.georgiev)
[ Triage 2017/02/20: P3 ]
Priority: -- → P3

I'm closing this bug as WONTFIX per:

"The Mortar experiment has concluded. Mozilla does not consider the PDF use case justifies the burden of implementing and maintaining PDFium and a Pepper API implementation in Gecko."

Source: https://wiki.mozilla.org/Mortar_Project

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.