Closed Bug 1427452 Opened 2 years ago Closed 2 years ago

Implement a "Dark Mode" theme

Categories

(developer.mozilla.org :: Design, enhancement)

All
Other
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: luke.mcdougald, Unassigned)

References

Details

(Whiteboard: [specification][type:feature])

What problem would this feature solve?
======================================
Multiple IDEs and websites have implemented a "dark mode" UI setting. Mozilla Developer Network does not have a theme within an acceptable contrast range for these users. With this theme, users working in lower light settings (night reading, night developing, with light sensitivity issues, or other situations) will be able to better use Mozilla Developer Network.

Who has this problem?
=====================
All visitors to MDN

How do you know that the users identified above have this problem?
==================================================================
No experiment ran: if there is a night mode available it is inaccessible without outside knowledge of its location.

How are the users identified above solving this problem now?
============================================================
They are using the "reading mode" options in various browsers, overriding the site CSS, using OS-level contrast settings, or avoiding MDN for other options. 

Do you have any suggestions for solving the problem? Please explain in detail.
==============================================================================
MDN should implement a Dark Mode that mimics the comprehensive nature of Jetbrains IDEs, VS12/13/15/17, Sublime Text, etc.

Is there anything else we should know?
======================================
This would also help decrease the contrast disparity with the default color schemes of many shells, default Vim/Emacs/others, and many other tools.
Hi Luke, thanks for bringing this up. Unfortunately for a site like MDN adding a dark theme incurs a significant cost that has to be payed for every front-end facing change moving forward. Considering the benefits and the cost involved, we're not going to opt into that at the moment.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Worth noting is that some browsers are starting to implement dark modes that actually adjust site CSS automatically.
There are also some user style sheet solutions floating around you can use:
https://userstyles.org/styles/139747/a-mdn-darkly

Stylish was pulled from the marketplace for violation of data practices. I believe Stly-us is the current favourite custom styles extension.
Duplicate of this bug: 1493459
You need to log in before you can comment on or make changes to this bug.