Closed Bug 1427996 Opened 6 years ago Closed 6 years ago

Push notifications are no longer working on Mac OS

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 952453
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 + fixed

People

(Reporter: cmuntean, Assigned: qdot)

References

Details

(Keywords: regression)

[Notes]:
- The push notifications are not working for any websites (eg: Facebook) or add-ons (eg Tab notifier, SnoozeTabs or Screenshots) that use them.
- In order to reproduce the issue easier, I have created the STR using Firefox Screenshots.
- The issue is not reproducible on Windows or Linux.

[Affected versions]:
- Nightly 59.0a1

[Affected Platforms]:
- All Mac

[Steps to reproduce]:
1. Start the latest Nightly build and navigate to any website (eg: https://www.wikipedia.org/).
2. Right click on the page and choose the "Take a Screenshot" option from context menu.
3. Perform a selection on the page and click the "Save" button.
4. Observe the browser behavior.

[Expected result]:
- A push notification, which informs the user that the shot link was saved to clipboard, appears in the top right corner of the screen.

[Actual results]:
- No push notification is displayed.

[Regression]:
- It seems that this is a regression since is not reproducible with latest Beta 58.0b13. Using the mozregression tools I have fond the regression window:
- Last good revision: 03aebc551f9da0dfbe383c39d2fcb2f2975eeecc
- First bad revision: 8fd1d4a79a48211fb77a442a7ad38b7a78d720b1
- Pushlog: https://goo.gl/xtHpAK
- Looks like bug 952453 introduced this issue.

Kyle, can you please take a look at this issue?
See the bottom of bug 952453 comment 22 for a list of various macOS notification functionality that bug 952453 broke.

Simple test case to run on an HTTPS page:
1. run `Notification.requestPermission()` in the Web Console and grant permissions
2. run `new Notification("hello")` in the Web Console

Expected result:
The notification appears on the screen despite the fact that the macOS application is in the foreground

Actual result:
No notification appears. The notification goes directly into the notification center.
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(kyle)
Yup. Backing out Bug 952453 right now. Dupe'ing this bug against that and will continue work there since it's requiring a complete backout.
Assignee: nobody → kyle
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(kyle)
Resolution: --- → DUPLICATE
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.