Closed Bug 1428049 Opened 2 years ago Closed 2 years ago

Error when running Talos locally

Categories

(Testing :: Talos, defect)

defect
Not set

Tracking

(firefox59 fixed)

RESOLVED FIXED
mozilla59
Tracking Status
firefox59 --- fixed

People

(Reporter: igoldan, Assigned: ahal)

References

(Depends on 1 open bug)

Details

Attachments

(2 files)

Running |./mach talos-test -a tpaint| locally fails with following traceback:

15:05:49     INFO -  Invalid requirement: '../tools/mozterm'
15:05:49    ERROR -  Traceback (most recent call last):
15:05:49     INFO -    File "e:\workspace\mozilla-source\mozilla-central\objdir-frontend\testing\talos-venv\lib\site-packages\pip\req\req_install.py", line 78, in __init__
15:05:49     INFO -      req = Requirement(req)
15:05:49     INFO -    File "e:\workspace\mozilla-source\mozilla-central\objdir-frontend\testing\talos-venv\lib\site-packages\pip\_vendor\packaging\requirements.py", line 96, in __init__
15:05:49     INFO -      requirement_string[e.loc:e.loc + 8]))
15:05:49     INFO -  InvalidRequirement: Invalid requirement, parse error at "u'../tools'"
15:05:49     INFO -  You are using pip version 8.1.2, however version 9.0.1 is available.
15:05:49     INFO -  You should consider upgrading via the 'python -m pip install --upgrade pip' command.
15:05:49  WARNING - Return code: 1
15:05:49     INFO - retry: Failed, sleeping 60 seconds before retrying
15:05:52     INFO - Running post-action listener: _resource_record_post_action
15:05:52     INFO - Running post-action listener: _start_resource_monitoring
:ahal added this yesterday, I assume he would know of any fixes here.
Whiteboard: [PI:January]
Whiteboard: [PI:January]
I have a fix. I think this will also need another mozlog version bump (in my defense I had landed this before jgraham reminded me about version bumping yesterday).
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Comment on attachment 8939858 [details]
Bug 1428049 - [mozlog] Add mozterm as a mozlog dependency and version bump to 3.7,

https://reviewboard.mozilla.org/r/210170/#review215862

I tested the changes here and they resolve the bug. Thanks!

::: testing/mozbase/mozlog/setup.py:28
(Diff revision 2)
>        author_email='tools@lists.mozilla.org',
>        url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
>        license='MPL 1.1/GPL 2.0/LGPL 2.1',
>        packages=find_packages(),
>        zip_safe=False,
> -      install_requires=['blessings >= 1.3',
> +      install_requires=DEPS,

So, mozbase package will be searched for locally, then installed, right? I don't think you uploaded it to PyPI.
Attachment #8939858 - Flags: review?(igoldan) → review+
Comment on attachment 8939857 [details]
Bug 1428049 - [talos] Create a separate mozbase_source_requirements.txt when installing packages from the source dir,

https://reviewboard.mozilla.org/r/210168/#review215866
Attachment #8939857 - Flags: review?(igoldan) → review+
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c2de67592fbd
[talos] Create a separate mozbase_source_requirements.txt when installing packages from the source dir, r=igoldan
https://hg.mozilla.org/integration/autoland/rev/6310cc3692ff
[mozlog] Add mozterm as a mozlog dependency and version bump to 3.7, r=igoldan
(In reply to Ionuț Goldan [:igoldan], Performance Sheriffing from comment #6)
> ::: testing/mozbase/mozlog/setup.py:28
> (Diff revision 2)
> >        author_email='tools@lists.mozilla.org',
> >        url='https://wiki.mozilla.org/Auto-tools/Projects/Mozbase',
> >        license='MPL 1.1/GPL 2.0/LGPL 2.1',
> >        packages=find_packages(),
> >        zip_safe=False,
> > -      install_requires=['blessings >= 1.3',
> > +      install_requires=DEPS,
> 
> So, mozbase package will be searched for locally, then installed, right? I
> don't think you uploaded it to PyPI.

Yeah, both mozterm and mozbase packages will still be installed from the local source checkout. Also correct, I haven't uploaded mozlog 3.7 to pypi yet, I'll wait for this to get merged to central first, just in case it gets backed out.
https://hg.mozilla.org/mozilla-central/rev/c2de67592fbd
https://hg.mozilla.org/mozilla-central/rev/6310cc3692ff
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1428298
Depends on: 1428363
Depends on: 1447735
You need to log in before you can comment on or make changes to this bug.