Closed Bug 1428208 Opened 2 years ago Closed Last year

Restore support for RSA-PSS keys

Categories

(NSS :: Libraries, enhancement, P3)

3.35
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mt, Assigned: mt)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The changes for draft-23 in TLS split RSA-PSS usage in two.  New codepoints are used for RSA-PSS signatures that are made with RSA-PSS keys.  NSS currently uses the codepoints for RSAE keys even if an RSA-PSS key is used.  I have a patch, but it's unlikely to make NSS 3.35.
Attachment #8940011 - Attachment description: Bug 1427921 - Restore RSA-PSS support to draft-22 levels, r?ekr → Bug 1428208 - Restore RSA-PSS support to draft-22 levels, r?ekr
Assignee: nobody → martin.thomson
Priority: -- → P3
Comment on attachment 8940011 [details]
Bug 1428208 - Restore RSA-PSS support to draft-22 levels, r?ekr

Tim Taubert [:ttaubert] has approved the revision.

https://phabricator.services.mozilla.com/D351
Attachment #8940011 - Flags: review+
Comment on attachment 8940011 [details]
Bug 1428208 - Restore RSA-PSS support to draft-22 levels, r?ekr

Daiki Ueno [:ueno] has approved the revision.

https://phabricator.services.mozilla.com/D351
Attachment #8940011 - Flags: review+
Please update the blocks file to include bug 158750
Landed as 7a5ecfb8bf8c with the wrong bug number.
Blocks: 158750
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: 3.36 → 3.39
You need to log in before you can comment on or make changes to this bug.