Handle ExternalImage lock failure

RESOLVED FIXED in Firefox 59

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

unspecified
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

It is already added to WebRender by https://github.com/servo/webrender/pull/1668 , but it is not used by gecko.
Assignee: nobody → sotaro.ikeda.g
See Also: → 1426193
Comment on attachment 8940087 [details] [diff] [review]
patch - Handle ExternalImage lock failure

Review of attachment 8940087 [details] [diff] [review]:
-----------------------------------------------------------------

In failure cases, we return RawDataToWrExternalImage(nullptr, 0) in RenderBufferTextureHost::Lock and RenderSharedSurfaceTextureHost::Lock, and NativeTextureToWrExternalImage(0, 0, 0, 0, 0) in RenderDXGITextureHostOGL::Lock and RenderMacIOSurfaceTextureHostOGL::Lock. We may wish to switch to InvalidToWrExternalImage() instead to be consistent.
Thanks for the comment, I am going to update the patch.
Attachment #8940087 - Attachment is obsolete: true
Attachment #8941306 - Attachment is obsolete: true
Depends on: 1426193
See Also: 1426193
Blocks: 1426193
No longer depends on: 1426193
Attachment #8941741 - Flags: review?(nical.bugzilla)
Attachment #8941741 - Flags: review?(nical.bugzilla) → review+
Pushed by sikeda@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4a4c7d5443ab
Handle ExternalImage lock failure r=nical
https://hg.mozilla.org/mozilla-central/rev/4a4c7d5443ab
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1424791
You need to log in before you can comment on or make changes to this bug.