Closed Bug 1428444 Opened 2 years ago Closed 2 years ago

push-apk task failed: APK specifies a version code that has already been used

Categories

(Release Engineering :: Release Automation: Other, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1385401

People

(Reporter: aiakab, Unassigned)

Details

This is the push where the test failed: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&author=toros@mozilla.com&selectedJob=154355453

Link to a recent log:https://treeherder.mozilla.org/logviewer.html#?job_id=154355453&repo=mozilla-central&lineNumber=279

Part of that log:Traceback (most recent call last):
253
  File "/builds/scriptworker/bin/pushapkscript", line 9, in <module>
254
    load_entry_point('pushapkscript==0.4.1', 'console_scripts', 'pushapkscript')()
255
  File "/builds/scriptworker/lib/python3.5/site-packages/pushapkscript/script.py", line 119, in main
256
    loop.run_until_complete(async_main(context))
257
  File "/tools/python35/lib/python3.5/asyncio/base_events.py", line 387, in run_until_complete
258
    return future.result()
259
  File "/tools/python35/lib/python3.5/asyncio/futures.py", line 274, in result
260
    raise self._exception
261
  File "/tools/python35/lib/python3.5/asyncio/tasks.py", line 239, in _step
262
    result = coro.send(None)
263
  File "/builds/scriptworker/lib/python3.5/site-packages/pushapkscript/script.py", line 67, in async_main
264
    let_mozapkpublisher_download_google_play_strings
265
  File "/builds/scriptworker/lib/python3.5/site-packages/pushapkscript/googleplay.py", line 26, in publish_to_googleplay
266
    push_apk.run()
267
  File "/builds/scriptworker/lib/python3.5/site-packages/mozapkpublisher/push_apk.py", line 111, in run
268
    self.upload_apks(apks, l10n_strings)
269
  File "/builds/scriptworker/lib/python3.5/site-packages/mozapkpublisher/push_apk.py", line 77, in upload_apks
270
    apk_response = edit_service.upload_apk(apk['file'])
271
  File "/builds/scriptworker/lib/python3.5/site-packages/mozapkpublisher/common/googleplay.py", line 81, in _transaction_required
272
    return method(*args, **kwargs)
273
  File "/builds/scriptworker/lib/python3.5/site-packages/mozapkpublisher/common/googleplay.py", line 101, in upload_apk
274
    media_body=apk_path
275
  File "/builds/scriptworker/lib/python3.5/site-packages/oauth2client/_helpers.py", line 133, in positional_wrapper
276
    return wrapped(*args, **kwargs)
277
  File "/builds/scriptworker/lib/python3.5/site-packages/googleapiclient/http.py", line 840, in execute
278
    raise HttpError(resp, content, uri=self.uri)
279
googleapiclient.errors.HttpError: <HttpError 403 when requesting https://www.googleapis.com/upload/androidpublisher/v2/applications/org.mozilla.fennec_aurora/edits/11804849305488113961/apks?alt=json&uploadType=media returned "APK specifies a version code that has already been used.">
280
exit code: 1
I don't know how much time we should spend on this. The mid-term goal is to get maple on dep signing; the blocker is https://trello.com/c/eMul7piW/82-remove-release-signing-requirement-for-staging-releases .
Actually, ignoring comment 0 (since it's a clone), this looks like someone reran this task. Run 0 was successful, https://tools.taskcluster.net/groups/cJ_dBavXSym5ysDswMFrtw/tasks/e8aXVZm2R4qBD2GQEeq-Cg/runs/0 ; run 1 appears to have failed because it was already uploaded.
12:33 <aki> is there a way to find out why https://tools.taskcluster.net/groups/cJ_dBavXSym5ysDswMFrtw/tasks/e8aXVZm2R4qBD2GQEeq-Cg/runs/1 reran? (taskcluster-cli user?) run 0 was successful
12:38 <dustin> Jan 05 06:48:30 taskcluster-queue app/web.11: Authorized mozilla-ldap/jlorenzo@mozilla.com/taskcluster-cli for POST access to /v1/task/e8aXVZm2R4qBD2GQEeq-Cg/rerun 
12:38 <dustin> looks like you should ask jlorenzo 
12:41 <aki> ok
12:41 <aki> thank you!

This is very likely user error, but I may be wrong.
Flags: needinfo?(jlorenzo)
Sorry for the confusion. That's the first time pub(gp) gets a bug raise at a single failure on m-c. Thank you Arthur and Aki for your promptness!

I confirm this failure was expected. I reran a job to see if the latest version of the worker still allowed to run old task definition. Sadly, pub(gp) isn't an idempotent job. For more context, please see bug 1385401 comment 23.

From now on, I'll pin failures to the bug I work on. This will save sheriff some time.

Also, could you guys avoid to clone bugs without changing the title and the first comment? This will prevent people reading the people from being confused.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(jlorenzo)
Resolution: --- → DUPLICATE
Summary: enable chain of trust verification in pushapk → push-apk task failed: APK specifies a version code that has already been used
Duplicate of bug: 1385401
No longer blocks: 1351664, 1286297, 1352367, 1353303, 1353333
No longer depends on: 1307826, 1317783, 1352477
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.