sometimes we load service workers from normal ScriptLoader instead of CacheStorage

RESOLVED DUPLICATE of bug 1465670

Status

()

enhancement
P3
normal
RESOLVED DUPLICATE of bug 1465670
a year ago
9 months ago

People

(Reporter: bkelly, Unassigned)

Tracking

(Blocks 3 bugs)

Firefox Tracking Flags

(Not tracked)

Details

While investigating a failure in --verify of:

  dom/workers/tests/serviceworkers/browser_download_canceled.js

I noticed that sometime we load the service worker from a normal ScriptLoader path instead of using CacheStorage.  We try to support this in case someone wipes the disk, but its unclear why we would trigger it in a normal test --verify.

We should investigate what is going on here.
Priority: -- → P3
I think this was probably fixed by the changes in bug 1465670 so I'm going to dupe over to that.  Specifically there were cases where the ScriptLoader could go to the network for ServiceWorkers when it should not.  We removed those and made the control-flow much more straightforward, so I think that probably covers whatever was observed here.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1465670
You need to log in before you can comment on or make changes to this bug.