Closed Bug 1428551 Opened 5 years ago Closed 5 years ago

[Narrate][Windows] Reader mode text-to-speech UI is not shown for Czech-language articles (no voice for that language?)

Categories

(Toolkit :: Reader Mode, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: mstanke, Unassigned)

References

()

Details

From two users of Firefox 57 on Windows 10 I have got a report that the TTS button (Narrate). I was unable to confirm on Linux, but my friend was able to reproduce on Windows 7. "narrate.enabled" is "true".
(In reply to Michal Stanke (Mozilla.cz) [:MikkCZ][:mstanke] (use needinfo) from comment #0)
> From two users of Firefox 57 on Windows 10 I have got a report that the TTS
> button (Narrate). I was unable to confirm on Linux, but my friend was able
> to reproduce on Windows 7. "narrate.enabled" is "true".

This needs more information. It wfm on Windows 10. Any more details? Have people checked with a clean profile? Anything special about the win7 install or Firefox (ie does en-US vs cs language make a difference) ? What language article are they testing with?
Flags: needinfo?(mstanke)
In the time of reporting this, we have been testing on various articles on Mozilla.cz with Czech installation of Firefox (builds from Mozilla) and fresh profiles. Keeping the needinfo to test once again with more conigurations to give you all answers.
I have checked today with fresh profiles. Firefox 56.0.2 and 58.0.1 (both 64 bit) on W7 Home Premium Service Pack 1. Both Czech and English builds behave the same in both versions.

https://www.mozilla.cz/zpravicky/iot-od-mozilly-se-vraci/ (Czech): Narrate is missing.
https://blog.mozilla.org/blog/2018/02/06/announcing-project-things-open-framework-connecting-devices-web/ (English): Narrate is there with two voices available - "Default" and "Microsoft Anna - English (United States)".

Is there some system dependency for Narrate to work for different languages?
Flags: needinfo?(mstanke)
(In reply to Michal Stanke (Mozilla.cz) [:MikkCZ][:mstanke] (use needinfo) from comment #3)
> I have checked today with fresh profiles. Firefox 56.0.2 and 58.0.1 (both 64
> bit) on W7 Home Premium Service Pack 1. Both Czech and English builds behave
> the same in both versions.
> 
> https://www.mozilla.cz/zpravicky/iot-od-mozilly-se-vraci/ (Czech): Narrate
> is missing.
> https://blog.mozilla.org/blog/2018/02/06/announcing-project-things-open-
> framework-connecting-devices-web/ (English): Narrate is there with two
> voices available - "Default" and "Microsoft Anna - English (United States)".
> 
> Is there some system dependency for Narrate to work for different languages?

Yes, it relies on the text-to-speech implementation provided by the OS. If no text-to-speech implementation is available for the language of the content, it isn't provided.

So to be honest, it sounds like this is working as designed, because Microsoft isn't advertising that its text-to-speech implementation on Windows supports Czech. Eitan, can you confirm?

On macOS, I get offered "Zuzana (Czech)" as a voice, who reads the text in (as best I can tell, not actually speaking Czech!) reasonable Czech pronunciation (as opposed to using "Default", which is the regular English voice and sounds awful).
Flags: needinfo?(eitan)
Summary: [Narrate] Reader mode is missing text to speach on Windows → [Narrate][Windows] Reader mode text-to-speech UI is not shown for Czech-language articles (no voice for that language?)
Correct, this is not a bug.

If Czech is not available in TTS, the Narrate button won't be available.

Do we need a support article about this?
Flags: needinfo?(eitan)
(In reply to Eitan Isaacson [:eeejay] from comment #5)
> Correct, this is not a bug.
> 
> If Czech is not available in TTS, the Narrate button won't be available.
> 
> Do we need a support article about this?

Yeah, probably. Joni, is it possible to add some explanation for this on SUMO, perhaps on the existing page on reader mode? ( https://support.mozilla.org/en-US/kb/firefox-reader-view-clutter-free-web-pages )
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jsavage)
Resolution: --- → INVALID
Something like "Note: Reader Mode will detect the language of the article it's showing. If Windows/macOS/Linux does not have text-to-speech information for that language, this feature may not be available."
Thanks for looping me in. I've added a note to the article in the button description: "This button will show up only if Windows/Mac/Linux has Text-to-speech information in the language that the article is in."
Flags: needinfo?(jsavage)
You need to log in before you can comment on or make changes to this bug.