Closed Bug 1428555 Opened 2 years ago Closed 4 months ago

Remove support for exposeToUntrustedContent in XBL

Categories

(Core :: XBL, task, P2)

task

Tracking

()

RESOLVED WONTFIX

People

(Reporter: bgrins, Unassigned)

References

Details

(Whiteboard: [xbl-in-content])

Attachments

(1 file)

<marquee> is the only non-test consumer of this feature: https://dxr.mozilla.org/mozilla-central/search?q=exposeToUntrustedContent&redirect=true.  After Bug 1425874 it won't use this attribute anymore, so the platform feature and tests should be able removable.
Priority: -- → P2
Whiteboard: [xbl-in-content]
No longer blocks: war-on-xbl-in-content

This removes the exposeToUntrustedContent attribute in XBL.

Various tests have been moved from mochitest to mochitest-chrome so
the test script can still access to XBL methods and properties.

test_bug1086996.xhtml is removed because it is a regression test for
XBL videocontrols.

file_bug795275.xml is removed because content HTML can no longer
access the Components object via XBL.

Assignee: nobody → timdream
Status: NEW → ASSIGNED
Assignee: timdream → nobody
Status: ASSIGNED → NEW

Honestly, I think we are in a place to remove more XBL tests at this point, as the maintenance cost outweighs our use, but I don't think I am in a place to make these decisions.

Type: enhancement → task
No longer blocks: war-on-xbl

XBL is now disabled in Firefox (Bug 1583314) and is in the process of being removed from Gecko (Bug 1566221), so closing bugs requesting changes to its implementation as wontfix.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WONTFIX
No longer blocks: remove-xbl-implementation
You need to log in before you can comment on or make changes to this bug.