Drag and drop can unpin a different topsite than the one being dragged

VERIFIED FIXED in Firefox 59

Status

()

defect
P2
normal
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: andreio, Assigned: rrosario)

Tracking

unspecified
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 verified)

Details

Attachments

(4 attachments)

Reporter

Description

a year ago
Posted image att1.png
STR
* Have 6 topsites all pinned
* drag a topsite over the one to its right (will result in an empty gap)

Result
* The empty gap is automatically filled by the topsite that went from position 6 to 7, when this happens it also loses its pinned state.
Reporter

Comment 1

a year ago
Posted image att2.png
Reporter

Comment 2

a year ago
att1 shows initial state. att2 shows how amz when from position 6 to 2 and is now unpinned.
Assignee: nobody → rrosario
Iteration: --- → 1.27
Priority: -- → P2

Updated

a year ago
Iteration: 1.27 → 60.1 - Jan 29

Comment 3

a year ago
Just to be clear, from attachment 8940658 [details] to attachment 8940659 [details], reddit was dragged from the 2nd position to the 3rd position?

uiwanted: What would you expect to happen for:

1) the 2nd position
2) the pinned amazon site?

(The current behavior's reasoning is that because amazon would have been pushed from 6 to 7 with only 6 top sites shown, the user would have a hidden pinned site that couldn't get unpinned, so the code automatically unpins it. In this specific case, amazon is the next top site when there's no frecent sites, but if there had been frecent sites, e.g., mozilla.org, it would have filled in the 2nd position when dragging reddit to the right.)
Keywords: uiwanted

Comment 4

a year ago
Here's a screenshot of what I was describing in comment 3. The reason the 6th pinned default top site appears in the 2nd position is because there's nothing else better to fill in.

Updated

a year ago
Iteration: 60.1 - Jan 29 → 59.4 - Jan 15

Comment 6

a year ago
bryan provided the feedback to move towards the hole
Keywords: uiwanted

Comment 7

a year ago
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/eb1becf42a4f92b97878369938f8cf809793366b
Fix Bug 1428727 - better shifting of pinned sites during drag n drop

https://github.com/mozilla/activity-stream/commit/078a9e96f4f8d9dd480980f8721e7781f2039105
Merge pull request #3930 from rlr/bug1428727/dnd-better-algo

Fix Bug 1428727 - better shifting of pinned sites during drag n drop

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Blocks: 1431263

Updated

a year ago
Blocks: 1427358
I have verified that the issue is no longer reproducible on the latest Nightly build (Build ID 	20180121220252) using Windows 10 x64, Mac 10.12 and Ubuntu 14.04.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.