Closed Bug 1428788 Opened 7 years ago Closed 7 years ago

Options-window related to some Add-ons icons shown on toolbar cannot are blank in private mode

Categories

(WebExtensions :: Compatibility, defect)

57 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(firefox57 affected, firefox58 affected, firefox59 affected)

RESOLVED DUPLICATE of bug 1329304
Tracking Status
firefox57 --- affected
firefox58 --- affected
firefox59 --- affected

People

(Reporter: ricky.tigg, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180104170325

Steps to reproduce:

1. Install one of these add-ons: Disconnect or Lastpass.
2. Launch application Firefox for Linux by selecting 'Open a new Private window'.
3. Display the toolbar and left-click either Disconnect or Lastpass add-on.respective Icon.


Actual results:

Those add-ons' and many more add-ons' respective opened windows are blank (attachment).


Expected results:

When the application Firefox is launched in an ordinary way, each one of those same windows display its content as intended by the add-ons developers.
Component: Untriaged → WebExtensions: Compatibility
OS: Unspecified → Linux
Product: Firefox → Toolkit
Hardware: Unspecified → x86_64
Reproducible on Nightly 59.0a1, build ID 20171226205948 and Latest Release 57.0.4 on Ubuntu 16.04 x64.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Let's check to see if these are problems in the extension.
Flags: needinfo?(amckay)
Undoubtedly that can be done; I mentioned randomly only few of them. On the last thirty add-ons I had installed for occasional use, at least five of them were affected by the present issue. Testing all the add-ons available in the Mozilla Firefox collection would not seem at first sight to be indicated as a relevant test procedure.
Duplicate of bug 1329304?
Check the browser console (ctrl-shift-j) when you open the popup. If an error similar to the following is reported as a result:

> TypeError: backgroundPage is null

Then it's a duplicate of bug 1329304.
Filter output "TypeError: backgroundPage is null" doesn't produce any target.
Thanks Raymond.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: