On Firefox for Linux the application top bar cannot be hidden.

RESOLVED DUPLICATE of bug 1283299

Status

()

enhancement
RESOLVED DUPLICATE of bug 1283299
a year ago
a year ago

People

(Reporter: ricky.tigg, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Posted image Firefox_top-bar.png
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180104170325

Steps to reproduce:

On Firefox for Linux, there is no option available aimed to hide the top bar located on the top of the Menu bar (attachment).


Actual results:

Linux-users' screen valuable space is then monopolised by that bar which brings no advantage in term of use or comfort but reduces enough significantly web pages display area, so that pages do not have for themselves the optimal space they deserve and would be put in good use.   

My preference is to keep the Menu bar as displayed , but because of that bar  that forces itself as displayed user has no option to use Firefox for Linux in Full Screen mode even when the use of that mode would be normally avoided on Firefox for Windows. since that inadequate bar is not present there.


Expected results:

To have the display of Firefox for Linux identical to the one developed for Firefox for Windows OS.
This seems to be more of an enhancement than an issue in my opinion. 
However, I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Toolbars and Customization
Ever confirmed: true
(Reporter)

Comment 2

a year ago
Issue noticeable in context illustrated in attachment.

Comment 3

a year ago
Putting tabs in the titlebar is something that's being worked on in the dependencies of bug 1283299.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: gtktitlebar
You need to log in before you can comment on or make changes to this bug.