If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New windows won't "focus" if opened when all other Mozilla windows are minimized

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Stephen Snyder, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

If I try to open a new mozilla window (Browser window) using the mozilla link in
my quick launch taskbar (Win2k) when all other Mozilla windows are minimized (I
usually keep my mail window minimize), a window will appear, but be useless. By
'useless', I mean that URL address line will not take input. The menus all work,
and even book marks can bring up pages in the window... but not user input in
the address line will change it.

This has been a trait of Mozilla for a while on my machine.

Reproducible: Always
Steps to Reproduce:
1. Minimize all Mozilla Windows.
2. Click the Mozilla icon.
3. Step 3? There is no step 3.

Actual Results:  I get a window that will not work properly, as described above.

Expected Results:  A browser window. Sans issues.

Closing that window and then immediately repeating the above steps will create a
new window which works properly. Also, maximizing any Mozilla window, and doing
the saw returns a fully functional window.

Comment 1

16 years ago
I can reproduce on with a build from 0426 on Windows 98.

See also bug 130984, "Mozilla window brought by click on the quick launch icon
does not have focus".  I don't think this is a dup of bug 130984, because the
window sometimes appears behind other windows without window focus (grey
titlebar) and sometimes appears in front with window focus.
(Reporter)

Comment 2

16 years ago
I doubt this is a dup of bug 130984. Specifically, there is NO cursor in the
address bar, and no way to access or add input to the address bar (ie, type in a
URL), even though the window itself might be active and in focus. Nothing can
change this... the window must be closed and a new brower window opened.

Also, reproduction of this error is not limited to quick links. And way of
creating a new window through an icon does the same... quick link, start menu,
desktop icon, etc...  what seems to matter is that all other Mozilla windows are
minimized.

Updated

16 years ago
Blocks: 70812

Comment 3

16 years ago
I have this problem with Release Candidate 3 (2002052306) on Windows 2000 SP2.
The URL text field does not have focus and clicking on it does not give it
focus. While this is rather annoying, one workaround is to select Open Web
Location from the File menu (or press Ctrl-Shift-L). This brings up a dialog in
which you can enter a URL. After going to this URL, the URL field works properly
(it can get focus). Any chance this can be fixed for version 1.0?

Comment 4

16 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Added information:

This bug continues to present itself in Mozilla 1.1a on XP (I "upgraded" from 2k
to XP recently).

HOWEVER, I tried to reproduce this bug on an NT 4 SP6 system with Mozilla 1.0,
and it works just fine. I have NO idea what that means. (Considering installing
1.1a onto the NT machine to test it again.)

Comment 6

15 years ago
-> Bill Law for a look
Assignee: sgehani → law
(Reporter)

Comment 7

15 years ago
I have been trying everything with Moz 1.1. The issue seems to have corrected
itself. I can not reproduce this error.

(Just to be clear, this would be a WinXP environment running the final release
of Mozilla 1.1, complete install.)

Comment 8

14 years ago
I cannot reproduce this because when I click on the Mozilla link in my quick
launch task bar, it always brings up the profile manager, even when I use -P
default and have only the default profile.

Can anyone else confirm comment #7 that this is now WFM?
Product: Core → Mozilla Application Suite
Assignee: law → jag
QA Contact: pawyskoczka

Comment 9

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

8 years ago
(In reply to comment #8)
> I cannot reproduce this because when I click on the Mozilla link in my quick
> launch task bar, it always brings up the profile manager, even when I use -P
> default and have only the default profile.
> 
> Can anyone else confirm comment #7 that this is now WFM?

Have tested with SeaMonkey 1.1.17 and SeaMonkey 2.0b1-Candidate on Win2k and WinXP, and cannot reproduce this Bug. When I open a new Browser-Window while all other SeaMonkey Windows were minimized, the URLBar gets the focus and takes the Input. So I close this Bug now as wfm.

Feel free to reopen, if you can reproduce this with the current Builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.