Closed Bug 1429040 Opened 7 years ago Closed 2 years ago

Wrong server name shown in imap timeout messages

Categories

(MailNews Core :: Networking: IMAP, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1483485

People

(Reporter: bugzilla-mozilla, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20171226003912

Steps to reproduce:

I moved my IMAP server to a different domain, let's say from old.example.org to new.example.org. In the server settings of my Thunderbird account, I have entered the new server name, and all is fine - receiving and sending mails works as expected. Now new.example.org has a downtime is not reachable. After a while, Thunderbird shows a popup, saying that there was a time-out when trying to connect to old.example.org. I am really not sure where it gets that name from, because I cannot find any traces of old.example.org in my account configuration. The *only* place where it's still being used is the local copy of the IMAP data in the ImapMail sub-folder of my profile.



Expected results:

After changing the server address to new.example.org, Thunderbird should always reference the new server name, not the old one.
Clarifaction: By "The *only* place where it's still being used is the local copy of the IMAP data in the ImapMail sub-folder of my profile" I mean that the folder of the local copy has the same name as old server, but I don't expect the the folder name should be used anywhere in the UI for display of the server name.
Please go to "Tools > Options, Advanced, General", Config Editor. Type "hostname" into the search box. Edit the wrong entry.

TB maintains a hostname and a realhostname. I've never quite understood what that's about but I could do some research, well, bug 1414607 comment #2 gives a hint.
Thanks, I could indeed find the old server name there. It seems like the realhostname should be displayed in the time-out notification, just like in the status bar.
Component: Untriaged → Networking: IMAP
Product: Thunderbird → MailNews Core
Summary: Wrong server name shown in timeout messages → Wrong server name shown in imap timeout messages
Version: 52 Branch → 52
Gene, this could do with some clean-up. Can I get you interested?
Flags: needinfo?(gds)
This is probably just a variation on the "why not just change hostname and get rid of realhostname" question. Will leave NI on this but defer the "overdue notices".
See Also: → 1414607
Flags: needinfo?(gds)
Blocks: 1573690
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.