Closed Bug 1429125 Opened 2 years ago Closed 2 years ago

stylo: Lack of lazy frame construction on the browser chrome could affect stylo-chrome performance

Categories

(Core :: CSS Parsing and Computation, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- wontfix
firefox58 --- wontfix
firefox59 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In stylo the cost of non-lazy frame construction is larger, it may be worth to take a profile with it completely enabled...
I asked dbaron about that and he didn't recall why it was disabled on the first place.
Comment on attachment 8941322 [details]
Bug 1429125: Enable lazy frame construction in the browser chrome, but not XUL yet.

https://reviewboard.mozilla.org/r/211614/#review217382

Yeah, I can't see why we would need to disable this for chrome documents specifically.  Could it have been the idea that lazy frame construction didn't buy as much for chrome documents since for them we have the entire XML document loaded before constructing frames?  (I'm not even sure that's true, just a guess.)
Attachment #8941322 - Flags: review?(cam) → review+
Attachment #8941322 - Flags: review?(tnikkel)
Comment on attachment 8941322 [details]
Bug 1429125: Enable lazy frame construction in the browser chrome, but not XUL yet.

https://reviewboard.mozilla.org/r/211614/#review217384

Yeah, I only put that condition in in order to make landing lazyfc easier with less risk and still get us the biggest wins from it. It was intended to be temporary (that's been said before). Thank you for finally removing this condition!
Attachment #8941322 - Flags: review?(tnikkel) → review+
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2e705f777acd
Enable lazy frame construction in the browser chrome, but not XUL yet. r=heycam,tnikkel
https://hg.mozilla.org/mozilla-central/rev/2e705f777acd
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Depends on: 1439323
Assignee: nobody → emilio
You need to log in before you can comment on or make changes to this bug.