Closed Bug 1429365 Opened 2 years ago Closed 2 years ago

network-monitor.js, line 527: TypeError: this.sink is null

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox59 fixed)

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: valentin, Assigned: ochameau)

References

Details

Attachments

(1 file)

Go to https://en.wikipedia.org/wiki/Main_Page

Open developer tools to the console
Open Scratchpad
Paste in this code:

```

document.location.reload()


```

Hit Ctrl-R to run the code a few times.

Look at the terminal:
JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js, line 527: TypeError: this.sink is null
Thanks for the report!

I wasn't able to see the 'this.sink is null', but I saw the following error:

JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/shared/webconsole/network-monitor.js, line 458: NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.contentCharset]


@Ricky, can you try to repro this bug?

Honza
Has STR: --- → yes
Priority: -- → P3
Flags: needinfo?(rchien)
I can reproduce this bug.

Steps to reproduce:
1. Launch Nightly
2. Open Browser Console (Ctrl+Shift+J)
3. Enable Responsive Design Mode (Ctrl+Shift+M)
4. Change network throttling to "DSL"
5. Go to "https://www.mozilla.org"
6. Reload current page a few times (Ctrl+R)
Hmm... interesting. I'm sure I saw ` TypeError: this.sink is null` randomly in past but I cannot reproduce it locally now.

I believe this issue is reported properly but we need to find out the solid STR to reproduce it.


On the other hand, I'm seeing the following error spraying out unusually on terminal when visiting https://edition.cnn.com/ .

JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/tab.js, line 1647: TypeError: can't access dead object
JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/tab.js, line 1647: TypeError: can't access dead object
JavaScript error: resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/tab.js, line 1647: TypeError: can't access dead object
Flags: needinfo?(rchien)
I'm suffering this kind of trashing error messages regularly, which is really annoying.  I will keep watching this issue and find out the right STR. If you have new findings, please comment below. Thanks for reporting the issue.
Finding regression range is complicated by other errors, but I think below. Because, this error disappear with my str if "dom.script_loader.bytecode_cache.enabled = false"

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=62cd3bf2db56339a60b7af5e54cf01fd80549ece&tochange=ec038106d24cdfc01a6c99cf78e8f349018e11ff
Alex, do you have any idea of this? (please see comment 5)
Flags: needinfo?(poirot.alex)
For can't access dead object error, please see bug 1409705
This is a regression from bug 1372115. It looks like there is a race in netmonitor actor for files fetched from bytecode cache.
Depends on: 1372115
Flags: needinfo?(poirot.alex)
Comment on attachment 8942669 [details]
Bug 1429365 - Prevent this.sink is undefined exception for resources loaded from bytecode cache.

https://reviewboard.mozilla.org/r/212918/#review218696

Thank you Alex, this patch looks great to me and this.sink is undefined exception has gone away.
Attachment #8942669 - Flags: review?(rchien) → review+
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffe766bd6f33
Prevent this.sink is undefined exception for resources loaded from bytecode cache. r=rickychien
https://hg.mozilla.org/mozilla-central/rev/ffe766bd6f33
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Assignee: nobody → poirot.alex
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.