Closed Bug 1430360 Opened 2 years ago Closed 2 years ago

Update the clang svn revision for the clang-tidy build generated by toolchains

Categories

(Firefox Build System :: Source Code Analysis, enhancement)

enhancement
Not set

Tracking

(firefox59 wontfix, firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox59 --- wontfix
firefox60 --- fixed

People

(Reporter: andi, Assigned: andi)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Now are are using a very old revision for clang-tidy build toolchains:

https://dxr.mozilla.org/mozilla-central/source/build/build-clang/clang-tidy-linux64.json

The revision used is: 295482

I want to do this since a some checkers for clang-tidy and some options in clang-format that are present in our .clang-format file are not implemented into that version. 

I will update it to the latest svn revision.
This is the revision to witch we will bump to: 322435
Summary: Update the clang cvs revision for the clang-tidy build generated by toolchains → Update the clang svn revision for the clang-tidy build generated by toolchains
Comment on attachment 8942425 [details]
Bug 1430360 - Update the clang svn revision for the clang-tidy build generated by toolchains.

https://reviewboard.mozilla.org/r/212726/#review218406

::: build/build-clang/clang-tidy-macosx64.json:24
(Diff revision 1)
>      "as": "/builds/worker/workspace/build/src/clang/bin/clang",
>      "ar": "/builds/worker/workspace/build/src/cctools/bin/x86_64-apple-darwin11-ar",
>      "ranlib": "/builds/worker/workspace/build/src/cctools/bin/x86_64-apple-darwin11-ranlib",
>      "ld": "/builds/worker/workspace/build/src/clang/bin/clang",
>      "patches": [
> -      "llvm-debug-frame.patch",
> +      "llvm-debug-frame-for-r322435.patch",

Is it because the previous patch is used elsewhere?

BTW you should look for an actual reviewer for this?
Attachment #8942425 - Flags: review?(sledru)
Comment on attachment 8942425 [details]
Bug 1430360 - Update the clang svn revision for the clang-tidy build generated by toolchains.

https://reviewboard.mozilla.org/r/212726/#review218416

::: build/build-clang/clang-tidy-macosx64.json:24
(Diff revision 1)
>      "as": "/builds/worker/workspace/build/src/clang/bin/clang",
>      "ar": "/builds/worker/workspace/build/src/cctools/bin/x86_64-apple-darwin11-ar",
>      "ranlib": "/builds/worker/workspace/build/src/cctools/bin/x86_64-apple-darwin11-ranlib",
>      "ld": "/builds/worker/workspace/build/src/clang/bin/clang",
>      "patches": [
> -      "llvm-debug-frame.patch",
> +      "llvm-debug-frame-for-r322435.patch",

Because the previous patch didn't apply to the current revision.
Attachment #8942425 - Flags: review?(bpostelnicu)
Attachment #8942425 - Flags: review?(bpostelnicu) → review?(dustin)
Attachment #8942425 - Flags: review?(dustin) → review?(nfroyd)
Comment on attachment 8942425 [details]
Bug 1430360 - Update the clang svn revision for the clang-tidy build generated by toolchains.

https://reviewboard.mozilla.org/r/212726/#review218872

Thanks!
Attachment #8942425 - Flags: review?(nfroyd) → review+
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16dc5da96ab6
Update the clang svn revision for the clang-tidy build generated by toolchains. r=froydnj
Backout by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/28801573d161
Backed out changeset 16dc5da96ab6 for clang-tidy bustages on a CLOSED TREE
I'm looking other this, Currently I'm submitting different try jobs to see why this happening.
Flags: needinfo?(bpostelnicu)
Attachment #8942425 - Flags: review?(sledru)
Attachment #8942425 - Flags: review?(sledru)
It seems that upgrading to an official 5.0.1 release this has been added to the Darwin build of compiler-rt:
https://github.com/llvm-mirror/compiler-rt/commit/fcf0ff11cde6226ebeb7ccf7225802e747ba3ca0
I added an extra patch for the compiler-rt repo that removes that since when cross-building from linux to darwin this would have failed.
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d0db94ac5049
Update the clang svn revision for the clang-tidy build generated by toolchains. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/d0db94ac5049
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Product: Core → Firefox Build System
Duplicate of this bug: 1422717
You need to log in before you can comment on or make changes to this bug.