Closed Bug 1430640 Opened 4 years ago Closed 4 years ago

Button labels are cut in "Delete from history" dialog on localized build

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 59
Iteration:
59.4 - Jan 15
Tracking Status
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- verified

People

(Reporter: flod, Assigned: ursula)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Italian.png
Currently the "Delete from history" button is cut in an Italian build.

I expect other languages to have similar issues

it: Elimina dalla cronologia
fr: Supprimer de l’historique
nl: Verwijderen uit geschiedenis
Regressed with https://github.com/mozilla/activity-stream/pull/3799 exported in bug 1415812.

Looks like a combination of flex-wrap: nowrap; and width: 50%; causing problems here.
Blocks: 1415812
Flags: needinfo?(usarracini)
Keywords: regression
;) Fortunately the whole of bug 1415812 wasn't uplifted to 58.

https://public.etherpad-mozilla.org/p/58-uplift-patches

icons skip for 58
pick 337e4b7f feat(modal): Closes #3615 Provide an icon for the confirm dialog
pick c25a2345 chore(icons): Compress svg files with svgo 1.0.2 (#3810)
pick 72c6d680 fix(styles): Specify background-color to avoid setting other background-{size,*} values (#3819)
Oops! I can take a look at this.
Flags: needinfo?(usarracini)
Assignee: nobody → usarracini
Iteration: --- → 59.4 - Jan 15
Priority: -- → P1
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/fe987c3bd116ba681a36745a826e38e9bd7d51bc
Fix Bug 1430640 - Button labels are cut in 'Delete from history' dialog on localized build

https://github.com/mozilla/activity-stream/commit/5d387c405b515c791a8a703da5e76039060d1142
Merge pull request #3940 from sarracini/bug_1430640

Fix Bug 1430640 - Button labels are cut in 'Delete from history' dialog on localized build
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Blocks: 1431263
I have verified that the issue is no longer reproducible on the latest Nightly build (Build ID 	20180121220252) using Windows 10 x64, Mac 10.12 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.