Closed Bug 1430696 Opened 2 years ago Closed 2 years ago

Windows PGO is busted in MSVC 15.5.3

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1424281

People

(Reporter: tjr, Unassigned)

Details

Attachments

(2 files)

See Bug 1424281 (especially comment 5) for more info and a fix for Windows x64
:rillian - what are you thoughts on the win32 fix-hack?
Flags: needinfo?(giles)
I'm fine with it, but this is third_party code which gets updated to upstream's version periodically, so it won't stay fixed. If this is needed for future revisions, best to update the vendor script to apply the patch on import. That's https://hg.mozilla.org/mozilla-central/file/tip/python/mozbuild/mozbuild/vendor_aom.py
Flags: needinfo?(giles)
It would be good to restrict these to defined(_M_IX86) and defined(_M_AMD64) to limit the damage of the deoptimizations.
Product: Core → Firefox Build System
These patches landed as part of bug 1424281.
No longer blocks: VS15.6
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: VS15.6
No longer blocks: 1429807
No longer blocks: 1433171
You need to log in before you can comment on or make changes to this bug.