Sometimes APZ stops working

RESOLVED FIXED in Firefox 59

Status

()

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mstange, Assigned: kats)

Tracking

Trunk
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

20180115220459

I don't know how to reproduce this.

When I woke my Mac up this morning, my Firefox Nightly build was no longer able to scroll using the touchpad or by dragging the scrollbar thumb. Scrolling with the arrow keys and the space bar is still working.
This affects all tabs in all windows.
This appears to be because we're falling back to Basic Compositor on the main window on OS X, and the WR hit-test doesn't work in that case. The falling back is because of bug 1377321, however when I back that patch out locally I just get a blank white window instead. I verified that the regression is from that by running inbound builds before and after that landed, though. So either my local set up is hosed (in terms of testing the backout) or something else landed since that patch to break WR-enabled OS X.
Blocks: 1377321
Oh, it was my local setup that was hosed.
Assignee: nobody → bugmail

Comment 4

a year ago
mozreview-review
Comment on attachment 8942996 [details]
Bug 1430797 - Allow webrender on eWindowType_child, so that it is used on OS X.

https://reviewboard.mozilla.org/r/213260/#review219000
Attachment #8942996 - Flags: review+
Attachment #8942996 - Flags: review?(mstange)
Reporter

Comment 5

a year ago
mozreview-review
Comment on attachment 8942996 [details]
Bug 1430797 - Allow webrender on eWindowType_child, so that it is used on OS X.

https://reviewboard.mozilla.org/r/213260/#review219002

Let's add eWindowType_dialog as well.
Attachment #8942996 - Flags: review+
Comment hidden (mozreview-request)

Comment 7

a year ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe6f236e1fb5
Allow webrender on eWindowType_child, so that it is used on OS X. r=nical
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 84dc1a6d0ede40081791534b28b9973a640067d1 -d d88cb52f392d: rebasing 442751:84dc1a6d0ede "Bug 1430797 - Allow webrender on eWindowType_child, so that it is used on OS X. r=mstange,nical" (tip)
merging widget/nsBaseWidget.cpp
warning: conflicts while merging widget/nsBaseWidget.cpp! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Hmm it autolanded the old version (which I triggered before Markus' comment). I'll land a follow-up with the eWindowType_dialog change.

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fe6f236e1fb5
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59

Comment 11

a year ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f05239cea76c
Follow-up to address review comment. r=mstange
You need to log in before you can comment on or make changes to this bug.