Closed Bug 143091 Opened 21 years ago Closed 21 years ago

No email to the qa contact when creating bugs

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.15
x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: jussi, Assigned: gerv)

Details

Attachments

(1 file)

When the default qa contact has only the add/remove option enabled in her email
preferences, she will not get any email when a bug is submitted.

When I was looking into this a bit I found that in post_bug.cgi, the qa_contact
field is referenced differently in a few places. So this could be the cause.

post_bug.cgi Line 143:
        $::FORM{'qa_contact'} = $qa_contact;

post_bug.cgi Lines 290-292:
if (defined $::FORM{qacontact}) {
    push (@ARGLIST, "-forceqacontact", DBID_to_name($::FORM{qacontact}));
}
I'll get this.

Gerv
Assignee: myk → gerv
Target Milestone: --- → Bugzilla 2.16
Attached patch Patch v.1Splinter Review
This fixes the obvious bug; I'm not completely convinced that it fixes the
problem, as I'm finding this difficult to test.

Gerv
Yes, this fixes it for me.
Keywords: patch, review
Comment on attachment 82849 [details] [diff] [review]
Patch v.1

2xr= justdave
this is pretty obvious
Attachment #82849 - Flags: review+
Fixed.

Checking in post_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/post_bug.cgi,v  <--  post_bug.cgi
new revision: 1.52; previous revision: 1.51
done

Gerv
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.