Closed Bug 1431014 Opened 4 years ago Closed 4 years ago

Authentication popup does not play well with password manager

Categories

(Toolkit :: Password Manager, enhancement)

52 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 227632

People

(Reporter: Ulrich.Windl, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20171228000000

Steps to reproduce:

If a site us using BASIC AUTH (without a login page), Firefox pops up an authentication dialog, requesting user and password.


Actual results:

The popup dialog does not play well with the built-in password manager when different usernames are available for authenticating to a specific site.  So the user is not presented a pulldown list with available user names. It may not be a common case, but especially developers testing authentication do such things sometimes.


Expected results:

The user name field in the authentication popup should work the same way as the user name field of a regular login page: If multiple accounts are known for that site, allow to select on of those.
Severity: normal → enhancement
Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Closed: 4 years ago
Component: Untriaged → Password Manager
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 227632
You need to log in before you can comment on or make changes to this bug.