Closed Bug 1431023 Opened 2 years ago Closed 2 years ago

npm install still fails when run from console folder

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1431457

People

(Reporter: ochameau, Unassigned)

References

(Blocks 1 open bug)

Details

$ cd devtools/client/webconsole
$ npm install
npm ERR! node v7.10.1
npm ERR! npm  v4.2.0

npm ERR! enoent ENOENT: no such file or directory, chmod '/mnt/desktop/gecko/devtools/client/netmonitor/node_modules/devtools-mc-assets/sync.js'
npm ERR! enoent ENOENT: no such file or directory, chmod '/mnt/desktop/gecko/devtools/client/netmonitor/node_modules/devtools-mc-assets/sync.js'

...

npm ERR! webconsole@0.0.1 preinstall: `cd ../netmonitor && npm install && cd ../webconsole`


By the way, is there any readme/doc specific to npm setup/tests for the console?
Actually, the error is in netmonitor.
$ cd devtools/client/netmonitor
$ npm install
npm ERR! enoent ENOENT: no such file or directory, chmod '/mnt/desktop/gecko/devtools/client/netmonitor/node_modules/devtools-mc-assets/sync.js'
Component: Developer Tools: Console → Developer Tools: Netmonitor
devtools-mc-asset is set in yarn.lock but not in package.json, is that it?
Also, devtools-mc-asset seems to only be hosted here: https://github.com/jasonLaster/devtools-mc-assets
It should be on devtools-html. All our own dependencies should be hosted on devtools-html as soon as we start using it in-tree.

I think this is related to https://github.com/jasonLaster/devtools-mc-assets/commit/5fad05cd70e7eeb47f283465b54b67e972430a69#diff-b9cfc7f2cdf78a7f4b91a753d10865a2
which may not be in the devtools-mc-assets v0.0.2 which is pulled by default.

If I apply this:
$ git diff .
diff --git a/devtools/client/netmonitor/package.json b/devtools/client/netmonitor/package.json
index cdb42aa2b1eb..931c6aeb7933 100644
--- a/devtools/client/netmonitor/package.json
+++ b/devtools/client/netmonitor/package.json
@@ -11,6 +11,7 @@
     "devtools-contextmenu": "=0.0.3",
     "devtools-launchpad": "=0.0.103",
     "devtools-modules": "=0.0.32",
+    "devtools-mc-assets": "^0.0.5",
     "devtools-source-editor": "=0.0.3",
     "jszip": "^3.1.3",
     "react": "=15.6.1",

I get an error on launchpad:
npm ERR! enoent ENOENT: no such file or directory, chmod '/mnt/desktop/gecko/devtools/client/netmonitor/node_modules/devtools-launchpad/node_modules/devtools-mc-assets/sync.js'
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1431457
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.