[Wayland] with WebRTC playback device sharing indicator is not shown

RESOLVED FIXED in Firefox 67

Status

()

defect
P3
normal
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 affected, firefox67 fixed)

Details

Attachments

(1 attachment)

Firefox on wayland crashes when I open the following site with an USB camera:

https://webrtc.github.io/samples/src/content/getusermedia/gum/

WebRTC playback device sharing indicator is not shown.
> Firefox on wayland crashes when I open the following site with an USB camera:
> 
> https://webrtc.github.io/samples/src/content/getusermedia/gum/

It works on my environment without crash.

Camera: Logitech C910

$ hg id -i
3cfc35010196

$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04 LTS"

$ env | grep -e XDG_CURRENT_DESKTOP -e DISPLAY
WAYLAND_DISPLAY=wayland-0
XDG_CURRENT_DESKTOP=ubuntu:GNOME

But the indicator isn't shown yet:

Gdk-Message: 15:59:45.814: Window 0x7f599f102500 is a temporary window without parent, application will not be able to position it on screen.
Gdk-Message: 15:59:45.814: Window 0x7f599f102500 is a temporary window without parent, application will not be able to position it on screen.
Assignee

Comment 2

11 months ago
It works fine for me with trunk & Fedora 28, even the indicator is shown.
Assignee

Comment 3

2 months ago

eWindowType_child window (a window defined by GdkWindow only) is not supported on Wayland
as we need moz_container to provide wl_surface to draw into.

As a workaroud create a regular toplevel window instead of child on Wayland to enable
rendering and window manipulation.

Assignee

Updated

2 months ago
Duplicate of this bug: 1534380
Assignee

Updated

2 months ago
Keywords: checkin-needed

Comment 5

2 months ago

Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7348960f8da
[Wayland] Render eWindowType_child as a toplevel window on Wayland, r=ashie

Keywords: checkin-needed

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
QA Whiteboard: [qa-67b-p2]
You need to log in before you can comment on or make changes to this bug.