Closed Bug 1431674 Opened 2 years ago Closed 2 years ago

If a video is playing while you sign into a youtube account, the video freezes.

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
platform-rel --- ?
firefox-esr52 --- unaffected
firefox57 --- unaffected
firefox58 --- wontfix
firefox59 + verified
firefox60 --- verified

People

(Reporter: oana.botisan, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [platform-rel-youtube])

[Affected versions]:
- 58.0 -build 6

[Affected platforms]:
- Windows 10 x64
- Ubuntu 16.04 x64
- macOS 10.13

[Preconditions]:
- Autoplay is on 

[Steps to reproduce]:
1. Open https://www.youtube.com/ in two tabs.
2. Play a video in one of the tabs.
3. In the other tab sign in into a valid youtube account.
4. Let the video play until the end.
5. Wait for the next video to begin and watch behaviour.

[Expected result]:
- The video starts to play without any problems.

[Actual result]:
- The video plays for about two seconds then it freezes. It can be played only if the page is refreshed. 

[Regression range]:
- I will try to find a regression as soon as possible, if there is one.

[Additional notes]:
- For clarifications please look at the attached .gif.
You can find the .gif at this link: https://imgur.com/a/mLsNE

Regression range:

- last good build: 2017-10-04 (20171004220309)
- first bad build: 2017-10-05 (20171005220204)
- pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c3b7759671deae73e40ebca01d7f23a326a4b8c2&tochange=19b32a138d08f73961df878a29de6f0aad441683

Mozregression suggested that this bug might be the one that caused the problem. 

Bug 1324883 - part2: Once a MediaElement receive document unload event, remove all MediaElements in gElementTable with the same uri. r=jwwang
Has STR: --- → yes
Keywords: regression
platform-rel: --- → ?
Whiteboard: [platform-rel-youtube]
Chris, is there someone you can recommend to look at this? Thanks.
Flags: needinfo?(cpearce)
This doesn't reproduce for me on Mac in 59b05.

Oana, could you see if it still does for you?
Flags: needinfo?(oana.botisan)
I check it on beta 59.0b5 and latest Nightly using Mac OS 10.11, Ubuntu 16.04 x32 and Windows 10 x64. The bug is still reproducing on every platform. 
I am using a gmail account to sign in. That might be the cause of the issue, maybe. Because yesterday I managed to reproduce the bug on DevEd 59.0b5 when I sign into my email account (gmail).
Flags: needinfo?(oana.botisan)
I'll try again using gmail (instead of @mozilla).
Flags: needinfo?(miket)
Ahh, yes. Just reproduced in 60 using my personal gmail account. No obvious network or console errors.
Flags: needinfo?(miket)
I tested with a yahoo account and the bug is reproducing. So I don't think that the issue is just gmail related.
This is indeed a regression from bug 1324883. The code to try to shutdown decoders when a new load starts is triggered by the YouTube, and it's causing the MSE decoder to be destroyed, blocking playback.

We can back out bug 1376321 to fix this; it doesn't seem that critical.
Assignee: nobody → cpearce
Flags: needinfo?(cpearce)
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c900339ffe3d
Backed out changeset 3e22200b7e83. r=backout
https://hg.mozilla.org/integration/mozilla-inbound/rev/aab04cb5b815
Backed out changeset 9d197f1860e6. r=backout
To be more explicit, the intent of bug 1376321 was to clear the MediaCache when a tab was closed or CTRL+F5 was pressed. However this has the adverse effect of shutting down the video element when a new MediaSource (which doesn't use the MediaCache) is attached to a previously playing media element under some conditions, in particular on YouTube when a user signs in on another YouTube tab.

We should uplift the backout.
Flags: needinfo?(cpearce)
https://hg.mozilla.org/mozilla-central/rev/c900339ffe3d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
let's get this on the tracking list for 59.
(In reply to Chris Pearce (:cpearce) from comment #10)
> To be more explicit, the intent of bug 1376321 was to clear the MediaCache
> when a tab was closed or CTRL+F5 was pressed. [...]

I meant to say bug 1324883 here, and elsewhere in this bug where I mentioned 1376321...
Blocks: 1324883
No longer blocks: block-autoplay
Flags: needinfo?(cpearce)
Verified on Nightly 60.0a1 (2018-03-09), Build ID: 20180309003239 on:
- Windows 10 x64
- Ubuntu 16.04 x64
- macOS 10.13
Bug is fixed.

Reproduced on the same OSes on Firefox 58.0
Status: RESOLVED → VERIFIED
I verified the fix on Firefox 59.0 using Windows 10 x64, macOS 10.13 and Ubuntu 16.04. The issue is not reproducing anymore.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.