MFCEmbed - "Match whole word only" in Find doesn't work

RESOLVED DUPLICATE of bug 269442

Status

()

Core
Embedding: APIs
RESOLVED DUPLICATE of bug 269442
15 years ago
3 years ago

People

(Reporter: amutch, Assigned: Chak Nanga)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.0.0+) Gecko/20020508
BuildID:    MFCEmbed - 5/8/2002 nightly build 

The "Match whole word only" option in the Find dialog does not work properly. 

Reproducible: Always
Steps to Reproduce:

1. Open any web page
2. Hit Ctrl-F to bring up the Find dialog
3. Check the option "Match whole word only"
4. Enter any sequence of chars that appear inside a word on the web page (eg.,
"stone" which appear inside the word "milestone")
5. Click on Find Next until your find ends "inside" the word (ie., until youf
find the "stone" part of the word "milestone")


Actual Results:  MFCEmbed matches every instance of the word, even when it is
inside a word.

Expected Results:  MFCEmbed should only match whole word matches of the word.

Comment 1

15 years ago
judging by bug 14871, this has never been implemented?
Summary: MFCEmbed - "Match whole word only" in Find doesn't work → MFCEmbed - "Match whole word only" in Find doesn't work
(Reporter)

Comment 2

15 years ago
This has not been implemented in Mozilla. However, it is implemented in MFCEmbed
so it affects embedding apps.

Comment 3

15 years ago
-> Chak
Assignee: adamlock → chak
(Assignee)

Comment 4

15 years ago
Cc:ing Conrad for additional info.
  A long time ago, embedding samples (not sure about MfcEmbed but this was true
for PPEmbed) used a hand-rolled find impl that supported "entire word"
searching. When everything was moved to nsIWebBrowserFind and the impl of that
was changed, we lost the feature of "entire word" searching :-( It's in the
nsIWebBrowserFind API, but it doesn't do anything.
  So, and this is why I cc'd akkana ;-), what we really need is to support
entire word searching in the nsIWebBrowserFind impl.

Comment 6

15 years ago
I have an RFE for that, bug 14871.  So far it hasn't been considered very high
priority, so I haven't looked at it.
(Reporter)

Comment 7

15 years ago
If this isn't going to be implemented soon or should be folder over into 14871,
please let us know so that we can modify the dialog appropriately on our end
(K-Meleon). The dialog in embedded examples should be modified as well but I'm
more concerned with the timeline on the functionality versus the dialog display.

Comment 8

15 years ago
If you look at bug 14871, it's marked Future, and no one has suggested so far
that it should be anything else.  If you disagree with that, you should make a
case for it in that bug.
(Reporter)

Comment 9

15 years ago
I don't think there has been a big clamor for this but I just wanted to make
sure I knew where this was going. Thanks for the clarification. I'll file a
separate bug for the dialog box. This could be duped on 14871 or otherwise
closed out. If the functionality is implemented down the road, it should apply
equally to all apps. 

Comment 10

15 years ago
duping per reporter's last comment



*** This bug has been marked as a duplicate of 14871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 269442
You need to log in before you can comment on or make changes to this bug.