Closed Bug 1431934 Opened 3 years ago Closed 3 years ago

Cannot delete Bing as search engine and it constantly returns and overrides default

Categories

(Firefox :: Search, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: philip, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

I deleted moist default search engines and set Google UK as default. I closed the browser and when I reopened, Bing, which was deleted reappeared and became default.

Subsequently, I deleted Firefox and reloaded and also did this again refusing the default bookmarks etc. 

Nothing will get rid of Bing.


Actual results:

Bing ket returning as default search engine, even though it should not be on the list at all.


Expected results:

Google UK should be default with Bing excluded from list.
Component: Untriaged → Search
(1) Please check the error console and report any errors you see there.
(2) Go to about:config and search for defaultenginename.  What are the values there?
(3) Do you have any language packs installed?
Flags: needinfo?(philip)
Drew 

Thanks for the help.


Control shift J
There are hundreds of errors. Most seem irrelevant e.g. unknown property and error in parsing value. Is there something specific to look for?


browser.search.defaultenginename;Google
browser.search.defaultenginename.US;data:text/plain,browser.search.defaultenginename.US=Google


Languages in Firefox
First [en-gb]
Second [en]
Flags: needinfo?(philip) → needinfo?(adw)
Thanks for the reply.

We're looking for errors in Firefox itself, not errors in web pages.  If you search/filter for the following terms in the error console, does anything show up?

firefox
Services.search
nsSearchService
nsISearchEngine
Flags: needinfo?(adw) → needinfo?(philip)
The searches yielded nothing. All that I have with any connection to Firefox is

Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src https://bugzilla.mozilla.org 'nonce-7d1kZ58XixHbttx8Of1LfekWS7AU6aepVMgbVRE55trSsMQy' 'unsafe-inline' 'unsafe-eval' https://www.google-analytics.com"). Source: ;!function(){var t=0,e=function(t,e){ret....  show_bug.cgi:1

Unknown property 'enable-background'.  Declaration dropped.  moz-fav-bw-rgb.svg

And some other similar unknown properties to do with box shadow and outline.
Flags: needinfo?(philip) → needinfo?(adw)
Hmm, I'm not sure then.  CC'ing Mike and Florian in case they have ideas.
Flags: needinfo?(adw)
Can you go to about:addons and see if you have any add-ons installed?

Also, can you go to about:config and see if there is a value set for the preference distribution.id.
Sorry. No sign of preference distribution.id in about:config.

If precision helps, the issue is not with Bing but Bing Search Engine. When I restore default search engines Bing reappears but not this one. It only comes back when I leave Firefox and then return.

Thanks for your help to date.
Flags: needinfo?(mozilla)
Flags: needinfo?(adw)
Could you please go to about:telemetry and type 'search' in the 'Find in all sections' searchbox in the top right corner? After doing this you should see 4 or 5 lines starting with "defaultSearchEngine". Could you please copy/paste them here? Thanks!
defaultSearchEngine 	other-Google UK
defaultSearchEngineData.name 	Google UK
defaultSearchEngineData.loadPath 	[http]mycroftproject.com/google-uk.xml
defaultSearchEngineData.origin 	verified
Flags: needinfo?(florian)
(In reply to philip from comment #9)
> defaultSearchEngine 	other-Google UK
> defaultSearchEngineData.name 	Google UK
> defaultSearchEngineData.loadPath 	[http]mycroftproject.com/google-uk.xml
> defaultSearchEngineData.origin 	verified

Is this right after setting your default engine back to Google UK yourself, or is it at a time when searching would use Bing?
Flags: needinfo?(florian)
This is the other version!

defaultSearchEngine 	other-Bing Search Engine
defaultSearchEngineData.name 	Bing Search Engine
defaultSearchEngineData.loadPath 	[other]addEngineWithDetails
defaultSearchEngineData.origin 	verified
Flags: needinfo?(florian)
I have just discovered a new angle. If I do not delete Bing Search Engine but make Google UK the default, that seems to stick although I haven't tested this rigorously yet.
Flags: needinfo?(florian)
Could you please check in about:config if a general.config.filename preference exists?
general.config.filename;dsengine.cfg

It does seem that leaving Bing Search Engine in place keeps Google as default.
Flags: needinfo?(florian)
Argh. Can you send me the dsengine.cfg file? It should be in the same location as your Firefox executable.
Flags: needinfo?(mozilla)
Flags: needinfo?(florian)
Flags: needinfo?(adw)
(In reply to Mike Kaply [:mkaply] from comment #15)
> Argh. Can you send me the dsengine.cfg file?

Please cc me :-).
This does appear to be active hijacking:

https://www.google.com/search?q=%22dsengine.cfg%22&ie=utf-8&oe=utf-8

I'm investigating whether we can find out from Bing who is doing this and mitigate.

We're doing work for the future that should eliminate these vectors of attack.
That does seem to have done the trick. To confirm, I deleted dsengine.js from the Firefox defaults/pref directory and dsengine.config from the main Firefox program directory.

Thanks to all who teamed up to beat this hijacker.
I'm going to mark this as fixed since we fixed this problem, but putting a see also to the "kill autoconfig" bug.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
See Also: → 1434655
We may have spoken too soon. Those two deleted files came back when I rebooted the PC. Obviously, this made Bing Search Engine the default again. I have deleted once more and will report back if there are further problems.
Even with those files deleted, Bing Search Engine seems to be hijacking Firefox again.
So it appears you have some application installed that is causing this.

Can you go to the uninstall list for Windows programs and sort them by date? Look for an app that was installed around when you started seeing this problem.
You need to log in before you can comment on or make changes to this bug.