[css-align] 'left' and 'right' should parse as invalid in block/cross-axis alignment

RESOLVED DUPLICATE of bug 1430817

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1430817
2 years ago
2 years ago

People

(Reporter: jfernandez, Assigned: emilio)

Tracking

57 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180104112904

Steps to reproduce:

1- Load the attached test case


Actual results:

Once the test case is loaded it'll show the specified and computed values for align-self, align-items and align-content CSS properties and the values that they should show.

The three properties show incorrect specified and computed values


Expected results:

The loaded tests show that both specified and computed values match the expected one. 

This is the current syntax for the evaluated CSS properties:

https://drafts.csswg.org/css-align-3/#align-self-property
https://drafts.csswg.org/css-align-3/#align-items-property
https://drafts.csswg.org/css-align-3/#align-justify-content

See the CSS WG discussion about the syntax change:

https://github.com/w3c/csswg-drafts/issues/1403
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Priority: -- → P3
This bug looks like duplicated from #1430817
(In reply to Javier Fernandez from comment #2)
> This bug looks like duplicated from #1430817

Umm, it seems bug #1430817 only talks about Content Distribution properties, so perhaps this is not exactly duplicated.
(In reply to Javier Fernandez from comment #3)
> (In reply to Javier Fernandez from comment #2)
> > This bug looks like duplicated from #1430817
> 
> Umm, it seems bug #1430817 only talks about Content Distribution properties,
> so perhaps this is not exactly duplicated.

Yeah, I'll fix the other ones in this bug too.
Assignee: nobody → emilio
Depends on: 1430817
I fixed all of them in bug 1430817.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1430817
You need to log in before you can comment on or make changes to this bug.