Closed Bug 1432216 Opened 4 years ago Closed 4 years ago

allow creation of multiple sidebars

Categories

(Firefox :: General, defect)

57 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1328776

People

(Reporter: ultrafox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20180103231032

Steps to reproduce:

When I try to use multiple add-ons (or built-in features) that utilize a sidebar, only one can be used at a time in the current sidebar.


Actual results:

The user discovers that only one feature can be used at a time in the one sidebar that Firefox provides.


Expected results:

Here is what some users would prefer: Imagine that the user could turn on two (or even more) sidebars. Now, the user could, for example, use the "Tree Tabs" add-on in a left sidebar while using Firefox's native Bookmarks feature in a right sidebar.

Advanced users know what they want/need and how to allocate screen space. As it is now, the 1-sidebar limit forces users to pick only the one feature/add-on they need most, and then have to use laborious menus for other features (or keep switching the sidebar back and forth).
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Untriaged → General
Resolution: --- → DUPLICATE
Duplicate of bug: 1328776
You need to log in before you can comment on or make changes to this bug.