Closed Bug 1432364 Opened 2 years ago Closed Last year

stop supporting cot v1

Categories

(Release Engineering :: Release Automation: Other, enhancement)

enhancement
Not set

Tracking

(firefox-esr60 fixed, firefox62 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- fixed
firefox62 --- fixed

People

(Reporter: aki, Assigned: aki)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Now that we've rolled out cotv2, let's stop supporting cotv1. This should make our cot verification more deterministic and maintainable, and will tie our tasks closer to the tree.

Let's wait for 59 to merge to release and make sure all the docker-image tasks are rebuilt with cotv2 supported task definitions. Let's make sure all the known ways to trigger+retrigger are cotv2 friendly - we may need to look at existing hooks and Treeherder's retrigger in bug 1420482.

Then let's:

- remove fuzzy task matching
- stop looking at commandlines
- stop maintaining docker image shas

We mainly need decision/action task verification, making sure our task definition came from one of those parent task types, and verifying our upstream artifacts haven't been altered at rest.
Releaserunner3 seems to have regressed to json-e==2.3.1. Let's fix that.
Attachment #8944639 - Flags: review?(mtabara)
Attachment #8944639 - Flags: review?(mtabara) → review+
Duplicate of this bug: 1395413
Pushed by asasaki@mozilla.com:
https://hg.mozilla.org/build/puppet/rev/ba69051bfe62
scriptworker 10.6.1 version bump. r=versionbump
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Pushed by asasaki@mozilla.com:
https://hg.mozilla.org/build/puppet/rev/787b06d437b2
scriptworker 10.6.2. r=versionbump
The patches to kill cotv1 are in bug 1459705.
Comment on attachment 8981602 [details]
bug 1432364 - remove comment about docker sha allowlists.

https://reviewboard.mozilla.org/r/247728/#review253786

Nice!
Attachment #8981602 - Flags: review?(gps) → review+
Keywords: leave-open
Pushed by asasaki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1cd2081db82
remove comment about docker sha allowlists. r=gps
https://hg.mozilla.org/mozilla-central/rev/e1cd2081db82
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
The comment about scriptworker (meaning constants.py) at https://firefox-source-docs.mozilla.org/taskcluster/docs/taskcluster/docker-images.html#docker-registry-images looks like it needs updating for this bug.
Attached patch doc updateSplinter Review
Attachment #8988577 - Flags: review?(nthomas)
Attachment #8988577 - Flags: review?(nthomas) → review+
Pushed by asasaki@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f39c27cbd36d
remove scriptworker requirement for docker images. r=nthomas
You need to log in before you can comment on or make changes to this bug.