Closed Bug 1432411 Opened 2 years ago Closed 2 years ago

Crash in mozilla::layers::CanvasClientSharedSurface::UpdateRenderer

Categories

(Core :: Graphics: Layers, defect, critical)

59 Branch
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: philipp, Assigned: milan)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-a2ec6c66-ae81-4510-b465-b1ee20180123.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll mozilla::layers::CanvasClientSharedSurface::UpdateRenderer gfx/layers/client/CanvasClient.cpp:415
1 xul.dll mozilla::layers::CanvasClientSharedSurface::Update gfx/layers/client/CanvasClient.cpp:380
2 xul.dll mozilla::layers::ShareableCanvasRenderer::UpdateCompositableClient gfx/layers/ShareableCanvasRenderer.cpp:234
3 xul.dll mozilla::layers::ClientCanvasLayer::RenderLayer gfx/layers/client/ClientCanvasLayer.cpp:29
4 xul.dll mozilla::layers::ClientLayer::RenderLayerWithReadback gfx/layers/client/ClientLayerManager.h:383
5 xul.dll mozilla::layers::ClientContainerLayer::RenderLayer gfx/layers/client/ClientContainerLayer.h:58
6 xul.dll mozilla::layers::ClientLayerManager::EndTransactionInternal gfx/layers/client/ClientLayerManager.cpp:359
7 xul.dll nsIFrame::ClearInvalidationStateBits layout/generic/nsFrame.cpp:7058
8 xul.dll nsTArray_Impl<mozilla::layout::FrameChildList, nsTArrayInfallibleAllocator>::AppendElement<mozilla::layout::FrameChildList, nsTArrayInfallibleAllocator> xpcom/ds/nsTArray.h:2185
9 xul.dll mozilla::layers::ClientLayerManager::EndTransaction gfx/layers/client/ClientLayerManager.cpp:423

=============================================================

these crashes (mainly in the content process) are regressing in volume cross-platform in firefox 59 since nightly build 20180106100308.

this would be the changelog to the build before:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a4362ce2d9fa82f62909532a1b534d214761341&tochange=ece8a96dfaa436c9bcf53105877b3923a264ae31
Jeff, there are some error messages with mImplicitMakeCurrent.  Also, does "EGL+" mean we're bypassing ANGLE?
Flags: needinfo?(jgilbert)
(In reply to Milan Sreckovic [:milan] from comment #1)
> Jeff, there are some error messages with mImplicitMakeCurrent.  Also, does
> "EGL+" mean we're bypassing ANGLE?

EGL+ includes ANGLE. ANGLE's our only EGL on Windows. (for now)
I'll take a look.
Assignee: nobody → jgilbert
Flags: needinfo?(jgilbert)
Any progress on this?
Flags: needinfo?(jgilbert)
I don't have time for this for the next week.
Assignee: jgilbert → nobody
Flags: needinfo?(jgilbert)
Blocks: 1427668
Has Regression Range: --- → yes
Comment on attachment 8949449 [details]
Bug 1432411: Wallpaper over the case where there is no Screen.

https://reviewboard.mozilla.org/r/218774/#review224722

I really want to know why screen could be null. Can you keep an assert that it's non-null?
Attachment #8949449 - Flags: review?(jgilbert) → review+
Assignee: nobody → milan
(In reply to Jeff Gilbert [:jgilbert] from comment #6)
> Comment on attachment 8949449 [details]
> Bug 1432411: Wallpaper over the case where there is no Screen.
> 
> https://reviewboard.mozilla.org/r/218774/#review224722
> 
> I really want to know why screen could be null. Can you keep an assert that
> it's non-null?

Will do, with gfxCriticalError that asserts in debug.
Pushed by msreckovic@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c13ba6039ceb
Wallpaper over the case where there is no Screen. r=jgilbert
https://hg.mozilla.org/mozilla-central/rev/c13ba6039ceb
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Please request uplift to beta when you get a chance.
Flags: needinfo?(milan)
Comment on attachment 8949449 [details]
Bug 1432411: Wallpaper over the case where there is no Screen.

Approval Request Comment
[Feature/Bug causing the regression]: 1427668
[User impact if declined]: crashes in noticable volume, regression
[Is this code covered by automated tests?]:
[Has the fix been verified in Nightly?]: yes, crashes stopped
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]:no, early return to a tested branch
[Why is the change risky/not risky?]:
[String changes made/needed]:
Flags: needinfo?(milan)
Attachment #8949449 - Flags: approval-mozilla-beta?
Comment on attachment 8949449 [details]
Bug 1432411: Wallpaper over the case where there is no Screen.

Even though the crash volume has gone down with b9 (which doesn't have this fix), this fix is still low risk and good to uplift, Beta59+
Attachment #8949449 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.