Closed Bug 1432455 Opened 3 years ago Closed 3 years ago

"make" build fails on AArch64 due to missing Hacl_Poly1305_64.o

Categories

(NSS :: Build, defect)

3.35
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ueno, Assigned: ueno)

References

Details

(Keywords: regression)

Attachments

(1 file)

I got the following compile failure when building 3.35 with make on AArch64:

Linux4.14_aarch64_cc_glibc_PTH_64_OPT.OBJ/Linux_SINGLE_SHLIB/chacha20poly1305.o: In function `Poly1305PadUpdate':
/builddir/build/BUILD/nss-softokn-3.35.0/nss/lib/freebl/chacha20poly1305.c:36: undefined reference to `Hacl_Poly1305_64_update'
/builddir/build/BUILD/nss-softokn-3.35.0/nss/lib/freebl/chacha20poly1305.c:39: undefined reference to `Hacl_Poly1305_64_update'
https://kojipkgs.fedoraproject.org/work/tasks/2825/24392825/build.log

It seems that the patches on bug 1399763 enabled the use of Hacl_Poly1305_64.c on AArch64 as well as x86_64, but only the gyp file was updated.
Attachment #8944691 - Flags: review?(franziskuskiefer)
Comment on attachment 8944691 [details] [diff] [review]
nss-build-hacl-poly1305-aarch64.patch

Review of attachment 8944691 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, thanks for fixing.
If you still use the make build system on aarch64, you can add a make job to Taskcluster and we'd catch something like this earlier.
Attachment #8944691 - Flags: review?(franziskuskiefer) → review+
Duplicate of this bug: 1433838
Note that while this might work, it doesn't match what the gyp backend does.

I'll also note that a fix apparently landed for this, but this bug was not updated accordingly.
Daiki, can you follow up on this?
Assignee: nobody → dueno
Flags: needinfo?(dueno)
(In reply to Mike Hommey [:glandium] from comment #3)
> Note that while this might work, it doesn't match what the gyp backend does.

The only difference I see from the logs is that the gyp build creates an intermediate static library, while the make build doesn't.  Do you mean anything else?

> I'll also note that a fix apparently landed for this, but this bug was not
> updated accordingly.

Sorry for not updating the status; I'm closing this as fixed, though I might file a bug to add a task to TC later.  The patch landed as:
https://hg.mozilla.org/projects/nss/rev/1668fafc1db4
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dueno)
Resolution: --- → FIXED
Target Milestone: --- → 3.36
Can you apply the fix to NSS_3_35_BRANCH as well? For one, Gentoo didn't backport it unlike Debian or FreeBSD.
Flags: needinfo?(dueno)
Keywords: regression
(In reply to Jan Beich from comment #6)
> Can you apply the fix to NSS_3_35_BRANCH as well? For one, Gentoo didn't
> backport it unlike Debian or FreeBSD.

Pushed to NSS_3_35_BRANCH as: https://hg.mozilla.org/projects/nss/rev/74e679158d1b
Flags: needinfo?(dueno)
See Also: → 1459739
You need to log in before you can comment on or make changes to this bug.