Open Bug 1432647 Opened 3 years ago Updated 2 years ago

Support themes with declarativeContent API

Categories

(WebExtensions :: General, enhancement, P5)

enhancement

Tracking

(Not tracked)

REOPENED

People

(Reporter: ntim, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [declarative])

I've been discussing with :jaws about how we can make dynamic/per-window/tab theming easier, and more performant. Atm, creating a dynamic/per-window theme requires setting up tab listeners/regular alarms/... which might not be super great for performance.

To solve this, I've created an experiment that themes stuff based on rules: https://github.com/nt1m/context-based-theming/blob/master/config.js


And it turns out there's a pretty similar API on Chrome:
https://developer.chrome.com/extensions/declarativeContent

I think it's worth implementing, because it helps for a lot of use cases like hiding page actions/injecting content scripts/creating dynamic themes...
Flags: needinfo?(mconca)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mconca)
Resolution: --- → DUPLICATE
Duplicate of bug: 1323433
Mike, does this cover the declarative theming use case ?
Flags: needinfo?(mconca)
You are right, Tim. I'll reopen this. I'm going to change the title to reflect your request to specifically support themes via the declarativeContent API.  I'm also going to create a tracking bug for declarativeContent API.
Severity: normal → enhancement
Status: RESOLVED → REOPENED
Flags: needinfo?(mconca)
Resolution: DUPLICATE → ---
Summary: Implement chrome.declarativeContent API → Support themes with declarativeContent API
Whiteboard: [declarative content]
Blocks: 1435864
Priority: -- → P5
Product: Toolkit → WebExtensions
Whiteboard: [declarative content] → [declarative]
Depends on: 1506199
You need to log in before you can comment on or make changes to this bug.