Closed Bug 1432681 Opened 2 years ago Closed 2 years ago

Consider how bookmark restores interact with the mirror

Categories

(Firefox :: Sync, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1426556

People

(Reporter: Lina, Unassigned)

References

(Blocks 1 open bug)

Details

Currently, an automatic or manual restore sets `syncChangeCounter > 1` and `syncStatus = UNKNOWN` for all restored bookmarks. A manual restore wipes the server and other clients. We could make this more durable by storing a flag in the mirror's `meta` table at the same time that we erase local bookmarks, so, if we fail to wipe the server or send the `wipeClient` command, we'll try again on the next sync.

An automatic restore should do a full merge instead of wiping the server. I think we'll want set `needsMerge = 1` for all bookmarks in the mirror, effectively treating it as a first sync with an existing local tree. (In the best case, Places restored from a recent enough backup, and we won't need to upload anything). Without that, we'll treat everything as locally changed, so older backups will be treated as newer than what's on the server.
Blocks: 1433177
Priority: -- → P2
Rolling this up into bug 1426556. No need to get fancy with `needsMerge`. :-)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426556
You need to log in before you can comment on or make changes to this bug.