Closed Bug 1433056 Opened 2 years ago Closed 2 years ago

Tab crashes when performing automatically selections using Firefox Screenshots

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- verified

People

(Reporter: cbadescu, Assigned: emilio)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

[Notes]:
- This issue is not reproducible for manual selections.

[Regression]:
- I've managed to find a regression window using Mozregression tool. Here are the results:
Last good revision: b529d05259c5f20af811903842655c5061ffb951
First bad revision: 60d339bdf87efaecb07bb108326d0c70a513aa4b
Pushlog: https://goo.gl/wxngyp
From the pushlog it seems that bug 1431474 has caused this. Emilio, can you please take a look at this issue?

[Affected versions]:
- Nightly 60.0a1
- Screenshots 25.0.0

[Affected Platforms]:
- All Windows
- All Mac OS
- All Linux

[Steps to reproduce]:
1. Open Nightly browser and navigate to a website.
2. Click the "Page actions" button and select "Take a Screenshot".
3. Perform an automatically selection.
4. Observe the behavior.

[Expected result]:
- The selection is performed.
Flags: needinfo?(emilio)
Thanks for the STR! I can repro this, thank you so much.

If this is a very frequent crash I can downgrade the assertion to a debug assertion for now.
Flags: needinfo?(emilio)
Assignee: nobody → emilio
Duplicate of this bug: 1433045
Comment on attachment 8945474 [details]
Bug 1433056: Account for pres shell destruction.

https://reviewboard.mozilla.org/r/215626/#review221318
Attachment #8945474 - Flags: review?(bugs) → review+
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/89401c18ca7d
Account for pres shell destruction. r=smaug
https://hg.mozilla.org/mozilla-central/rev/89401c18ca7d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Thanks for fixing this issue! I've retested it and is no longer reproducible on latest Nightly build 60.0a1 (2018-01-26), on Windows 10 x64, Mac 10.12.6 and Arch Linux 4.12.
Status: RESOLVED → VERIFIED
Crashes numbers decreased significantly since the patch landed, but there still are existing in nightly 60:
buildid 20180126035135: 14 crashes (12 installations)
buildid 20180126104626: 17 crashes (14 installations)
:emilio, should I open a new bug for them or reopen this one ?
Flags: needinfo?(emilio)
Let's file another one, those are different assertions that I'm interested in looking into, thanks!
Flags: needinfo?(emilio)
Depends on: 1470762
You need to log in before you can comment on or make changes to this bug.