No longer show the template for tracking & release notes requests

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
a year ago
2 months ago

People

(Reporter: sylvestre, Assigned: kohei)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

a year ago
In the past, when selecting the tracking request "?", we used to have a template which would tell the user to explain why.

I don't see it anymore.
For example, I tried on this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1433065
Assignee: nobody → dylan
Severity: normal → major
Status: NEW → ASSIGNED
Priority: -- → P1
(Reporter)

Comment 1

a year ago
Ditto for the release notes "relnote-firefox" flag.
Saw that here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1409973#c40
Summary: No longer show the template for tracking requests → No longer show the template for tracking & release notes requests
Is the template this comment stuff?
Flags: needinfo?(sledru)
I see "comment required", a link which produces the template, here (screenshot attached) though I had to change it to ? first.

Is this it or was it something else?
After we confirm what this is -- kohei, do you have any bandwidth to see if this changed?
Flags: needinfo?(kohei.yoshino)
(Reporter)

Comment 5

a year ago
yes, I confirm this but to be clear, the tracking request is really what matters :)
Flags: needinfo?(sledru)
So I think tracking_flag_change() isn't getting called now,
or at the very least it isn't making it to this part of code:

https://github.com/mozilla-bteam/bmo/blob/master/extensions/TrackingFlags/web/js/tracking_flags.js#L75-L89
So when I set breakpoints in the js, and change the selector to ?, I get text filled in.

https://screenshots.firefox.com/Z8rTT6xlk8idghWG/bugzilla.mozilla.org
but if I do not set breakpoints, nothing happens.
After using the debugger, I can't reproduce this. Even if I restart the browser.
What happened?
Posted file PR (obsolete) —
Need to work on the .htaccess rewrite rule but this should prevent this from bothering other people.
(Reporter)

Comment 11

9 months ago
Dylan, I am still experiencing this issue with ublock origin
Flags: needinfo?(dylan)
I'll see about getting this landed then.
Flags: needinfo?(dylan)
(Reporter)

Comment 13

8 months ago
Sorry to be a pain about that but do you have an eta for this?
thanks
Flags: needinfo?(dylan)
Renaming tracking flags is a real pain at the moment, I'm hoping some other work will make doing this easier.
My first naive attempt didn't work.

I recommend not using ublock origin for bmo since bmo doesn't show ads in the meantime.
Flags: needinfo?(dylan)
Attachment #8955553 - Attachment is obsolete: true
So we have nothing to do here? I have enabled Tracking Protection by default in my Firefox but everything looks fine. These comment templates could be converted to temporary forms just like Bug 1489718 but it’s a separate issue.
Component: Extensions: BMO → Extensions: TrackingFlags
Flags: needinfo?(kohei.yoshino)
(Reporter)

Comment 16

3 months ago
We should just rename the script to avoid ublock blocking it.
Priority: P1 → --

This is on my radar.

Assignee: dylan → kohei.yoshino
Posted file GitHub Pull Request

The culprit was the JavaScript file name tracking_flags.js, so simply renaming it will solve the issue. Looks like the directory name TrackingFlags is not a problem.

Merged to master.

Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.