Closed Bug 1433085 Opened 2 years ago Closed 2 years ago

[TSF][e10s] Candidate window of Microsoft Pinyin disappeared after commiting part of composing string

Categories

(Core :: Widget: Win32, defect)

58 Branch
All
Windows
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1422230

People

(Reporter: taroxd, Assigned: masayuki)

References

Details

(Keywords: inputmethod)

Attachments

(1 file)

45.74 KB, application/x-zip-compressed
Details
Attached file attach.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180118215408

Steps to reproduce:

1. Type "nihao" in Microsoft Pinyin
2. Select "你" in the candidate window

I recorded some log as I did in https://bugzilla.mozilla.org/show_bug.cgi?id=1418747. In the attachment, 1.log is the log file with "nsTextStoreWidgets:5,ContentCacheWidgets:5,sync", 2.log with "nsTextStoreWidgets:5,IMEContentObserver:5,sync"


Actual results:

The candidate window disappeared. See the screenshot "what_happened.png" in the attachment.


Expected results:

It should not have disappeared. See the screenshot "expected.png" in the attachment.
Component: Untriaged → Widget: Win32
Product: Firefox → Core
Keywords: inputmethod
OS: Unspecified → Windows
Hardware: Unspecified → All
Got it. Thank you for the report and log files in bug 1418747.

According to the log, when you commit a part of composing string, MS Pinyin does:
1. Commits composition only with committed part. (i.e., only "你" in your STR)
2. Computes next character rect of "你".
3. Starts composition again after "你" with "hao".

Therefore, GetTextExt() doesn't do any hack since there is no composition.
Assignee: nobody → masayuki
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
See Also: → 1418747
Summary: Candidate box of Microsoft Pinyin disappeared after selecting the first character → [TSF][e10s] Candidate window of Microsoft Pinyin disappeared after commiting part of composing string
> User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

Oh, you tested with 58. Do you still reproduce this bug with 59 beta? I fixed bug 1422230 and perhaps, it may fix your symptom too.
Flags: needinfo?(taroxd)
You can download beta build from here:
https://www.mozilla.org/en-US/firefox/channel/desktop/

Unfortunately, I don't know if zipped build is available for avoiding install.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(taroxd)
Resolution: --- → DUPLICATE
Duplicate of bug: 1422230
You need to log in before you can comment on or make changes to this bug.