Need switch to hide misc panel on Form Manager

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: yinglinxia, Unassigned)

Tracking

({intl, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 rtm] [Needs a=] custrtm-)

Attachments

(2 attachments)

Reporter

Description

17 years ago
We had a switch in all.js before,
   pref("wallet.miscPanel.hide",               true);
but it's not working now, set it to "true" won't hide the "Personal" panel.

Reproducible: Always
Steps to Reproduce:
1. Set "wallet.miscPanel.hide" to true.
2. Launch Mozilla and start Tools/Form Manager/Edit Form Info.

Actual Results:  The "Personal" panel is still on the UI.

Expected Results:  It should be hidden.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Keywords: intl, nsbeta1, regression

Updated

17 years ago
Blocks: 141008

Comment 2

17 years ago
Problem is that display:none has been deprecated in favor of hidden=true.  
Attaching a patch to update this file to use the latter method of hiding.
Status: NEW → ASSIGNED

Comment 4

17 years ago
Comment on attachment 83147 [details] [diff] [review]
display:none -> hidden=true

sr=jag
Attachment #83147 - Flags: superreview+

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
Comment on attachment 83147 [details] [diff] [review]
display:none -> hidden=true

r=sgehani
Attachment #83147 - Flags: review+

Comment 6

17 years ago
Checked in on trunk

Comment 7

17 years ago
yxia- can you verify the fix is good?

Updated

17 years ago
Keywords: adt1.0.0
Reporter

Comment 8

17 years ago
Verified in last night JA build, with morse's new checked in file, working good 
for Personal panel, didn't check others, but must be the same. Thanks a lot, 
morse.
teri - can you verify this on the trunk, and make sure no regressions were
introduced.
Keywords: approval
Whiteboard: [adt2 rtm] [Needs a=]

Comment 10

17 years ago
Verified this is fixed on Win XP trunk build 2002051408, Mac OS X trunk build
2002051403 and linux trunk build 2002051409

Comment 11

17 years ago
mark this bug as VERIFIED since it checked into the turnk and verified on the trunk.
Without that ADT may not adt+ it. 
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
mark it verified since qa said so
Status: RESOLVED → VERIFIED

Comment 13

17 years ago
adding adt1.0.0+.  Please get drivers approval before checking in to the 1.0
branch.  This can go in after RC3.
Keywords: adt1.0.0adt1.0.0+

Updated

17 years ago
Keywords: nsbeta1nsbeta1+
Comment on attachment 83147 [details] [diff] [review]
display:none -> hidden=true

a=brendan@mozilla.org on behalf of drivers for checkin to the 1.0 branch --
please check the patch in today, we're trying for rc3 based on tomorrow's
builds.  Thanks,

/be
Attachment #83147 - Flags: approval+

Comment 15

17 years ago
Checked in on 1.0 branch.
Keywords: fixed1.0.0

Updated

17 years ago
Blocks: 146292
No longer blocks: 141008

Updated

17 years ago
Whiteboard: [adt2 rtm] [Needs a=] → [adt2 rtm] [Needs a=] custrtm

Updated

17 years ago
Whiteboard: [adt2 rtm] [Needs a=] custrtm → [adt2 rtm] [Needs a=] custrtm-
Assignee: morse → nobody
Product: Core → Toolkit
QA Contact: tpreston → form.manager
Target Milestone: mozilla1.0 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.